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NOTE
For your own safety, please observe the warnings and safety instructions contained in this document.
Disclaimer of Liability

This document has been subjected to rigorous technical review 
before being published. It is revised at regular intervals, and any 
modifications and amendments are included in the subsequent 
issues. The content of this document has been compiled for 
information purposes only. Although Siemens AG has made best 
efforts to keep the document as precise and up-to-date as possible, 
Siemens AG shall not assume any liability for defects and damage 
which result through use of the information contained herein.

This content does not form part of a contract or of business 
relations; nor does it change these. All obligations of Siemens AG 
are stated in the relevant contractual agreements.

Siemens AG reserves the right to revise this document from time to 
time. 

Document Release: E50417-H1176-C070-A6.00
Edition: 02.2011
Product version: V4.50

Copyright

Copyright © Siemens AG 2011. All rigths reserved. 
The disclosure, duplication, distribution and editing of this 
document, or utilization and communication of the content are not 
permitted, unless authorized in writing. All rights, including rights 
created by patent grant or registration of a utility model or a design, 
are reserved.

Registered Trademarks

SIMATIC®, SIMATIC NET®, SIPROTEC®, DIGSI®, SICAM®, 
SIMEAS® and SINAUT® are registered trademarks of 
SIEMENS AG. An unauthorized use is illegal. 

All other designations in this document can be trademarks whose 
use by third parties for their own purposes can infringe the rights of 
the owner.
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Preface

Purpose of this manual

This manual describes the function and operational principles of the SIGRA 4 program for the analysis of fault 
records.

Target group

This manual is primarily aimed at those customers and their staff responsible for the analysis of fault events in 
the supply network in the context of power system management.

Validity of this manual

This manual is valid for SIGRA 4, V4.50V. 

Standards

SIGRA 4 has been designed in compliance with the ISO 9001:2008 quality guidelines.

Further assistance 

If you have any questions regarding SIGRA 4, please contact your regional Siemens Office.

Hotline

Our Customer Support Center provides around-the-clock support.

Phone: +49 (180) 524-7000
Fax: +49 (180) 524-2471
e-mail: support.energy@siemens.com

Training courses

If you are interested in our current training program, please contact our training center:

Siemens AG
Siemens Power Academy

Humboldtstr. 59
90459 Nürnberg

Tel.: +49 (911) 433-7005
Fax: +49 (911) 433-7929
Internet: www.siemens.com/energy/power-academy-td
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Notes On Safety

This manual does not constitute a complete catalog of all safety measures required for operating the equipment 
(module, device) in question, because special operating conditions may require additional measures. However, 
it does contain notes that must be adhered to for your own personal safety and to avoid damage to property. 
These notes are highlighted with a warning triangle and different keywords indicating different degrees of dan-
ger.

DANGER
Danger means that death or severe injury will occur if the appropriate safety measures are not taken.

✧ Follow all advice instructions to prevent death or severe injury.

WARNING
Warning means that death or severe injury can occur if the appropriate safety measures are not taken.

✧ Follow all advice instructions to prevent death or severe injury.

CAUTION
Caution means that minor or moderate injury can occur if the appropriate safety measures are not taken.

✧ Follow all advice instructions to prevent minor injury.

NOTICE
Notice means that damage to property can occur if the appropriate safety measures are not taken.

✧ Follow all advice instructions to prevent damage to property.

NOTE

is important information about the product, the handling of the product, or the part of the documentation in ques-
tion to which special attention must be paid.
4 SIPROTEC, SIGRA 4, Manual
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Qualified Personnel

Commissioning and operation of the equipment (module, device) described in this manual must be performed 
by qualified personnel only. As used in the safety notes contained in this manual, qualified personnel are those 
persons who are authorized to commission, release, ground and tag devices, systems, and electrical circuits 
in accordance with safety standards.

Use as Prescribed

The equipment (device, module) must not be used for any other purposes than those described in the 
Catalog and the Technical Description. If it is used together with third-party devices and components, these 
must be recommended or approved by Siemens.

Correct and safe operation of the product requires adequate transportation, storage, installation, and 
mounting as well as appropriate use and maintenance.

During the operation of electrical equipment, it is unavoidable that certain parts of this equipment will carry dan-
gerous voltages. Severe injury or damage to property can occur if the appropriate measures are not taken:

• Before making any connections at all, ground the equipment at the PE terminal. 

• Hazardous voltages can be present on all switching components connected to the power supply.

• Even after the supply voltage has been disconnected, hazardous voltages can still be present in the equip-
ment (capacitor storage).

• Equipment with current transformer circuits must not be operated while open.

• The limit values indicated in the manual or the operating instructions must not be exceeded; this also 
refers to testing and commissioning
5SIPROTEC, SIGRA 4, Manual
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1.1 General
The SIGRA 4 application program supports the analysis of fault events in your network. It offers a graphic dis-
play of the data recorded during the fault event and uses the values measured to calculate further variables, 
such as impedances, outputs or r.m.s. values, which make it easier for you to analyze the fault record.

You can then represent these variables in any of the following diagrams of the views 

• Time Signal diagrams
• Vector diagrams
• Circle diagrams
• Harmonics
• Fault locators

or in the

• Table

view.

DIGRA009.tif

Fig. 1-1 SIGRA 4, there are various diagram and table views available to display fault record data.

You can choose to display the signals of a fault record in the various views as either

• primary values or

• secondary values,

irrespective of the method of recording the measured values in the fault recorder.
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Apart from the actual signals it is also possible to display the fundamental component as well as the harmonics 
of each signal and thus even better recognize special features of the signal curves.

In addition to its graphical display options, SIGRA 4 offers the following tools to support fault record analysis:

Cursor 1 / Cursor 2

Cursor 1 and cursor 2 are assigned to the time axis.

If you move a cursor along the time axis you can read the related instants in the corresponding tables in all 
views.

In the Time Signal view, cursor 1 and cursor 2 are shown as vertical lines across all diagrams of the view.
In the Circle Diagram view they are displayed as crosshairs.

The transparency of the fault record analysis is increased by the color coding of the cursor. The color assign-
ment can be found in tables, cursor symbols, lines or crosshairs and in dialog boxes which refer to the cursor 
position (such as Synchronize Fault Records).

Table

If you want to know the exact value of a particular signal at a defined instant, assign a cursor to this signal. The 
table of the selected view then displays the signal name, the values and the instant specified by the cursor 
position.
The structure of the table can be freely configured in the View Properties dialog. The type of displayed values, 
such as r.m.s. value, extreme value, phase, etc., can be changed at any time.

You can temporarily hide part or all of the on-screen display of the table. To do this, simply drag the lower border 
of the table towards the top of the screen.

Tooltip

If you move the mouse pointer onto a signal of a diagram, a tooltip pops up which displays the signal name and 
value(s) of the respective sampling instant.

Zoom

Use the convenient zoom functions to define the ideal display size for the value profile in each view. You can 
either maximize or minimize the whole diagram or selected sections, or optimize the display scale. The 
Zoom - Optimize function can be used separately for the X-axis and the Y-axis. Furthermore, if you want the 
display scales of various diagrams of a view to be uniform, you can select the Match function.

Status bar

The status bar shows the function of the currently selected toolbar button, the frequency, the primary and sec-
ondary data of primary current and voltage transformers and the sampling rate.
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Parameter settings of the analysis

You can assign measured or calculated values to the individual diagrams of the graphical views or tables using 
the Assign Signals matrix or by simply using the drag-and-drop function.

Parameters defining the fault record display, such as the distribution of signals to specific diagram views and 
tables, color, line and font styles, etc. can be saved permanently in the form of User Profiles. These can then 
be assigned to other fault records by simply clicking the toolbar.

SIGRA 4 is equipped with a session memory which retains all settings and view arrangements of a session. 
This means that you can break off an analysis and, at a later point, simply resume where you left off.

Importing fault records

If you require a second fault record in order to analyze the data of a fault record, i.e. from the other end of the 
line, you can insert this in the current fault record analysis and evaluate the signal paths together.

Comment

The Comment dialog lets you file notes relevant to the fault record, such as the analysis results or notes for 
the planning dept., etc. 
Furthermore, you can add comments at any position of the curve representation of the fault record. These com-
ments can be stored with the fault record. You can thus assign your comments to important positions during 
evaluation. 

Data Export

The COMTRADE Export function lets you export data of a fault record, complete with calculated values, in 
COMTRADE format.

To export diagrams or tables to other applications, such as Word, Excel, Powerpoint, simply drag and drop 
them or use the Windows Clipboard (Copy/Paste). 

The properties dialog boxes let you define the appearance of the signals in the diagrams of the views.

View properties

The View Properties dialog lets you define settings which are applied to all diagrams of a single view, such as 
the display of gridlines or the font. It also lets you configure the table columns of the tables of the various views.

Diagram properties

This dialog box lets specify the properties of a diagram.
You can define properties, such as background color, axis name, gridlines or axis scale.

NOTE
The conventions used for the calculation and evaluation of variables under SIGRA 4 are explained in detail in 
chapter 5.
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Signal properties

You can also specify the display of individual signals.
The dialog lets you define the color, weight and style of a line or graphical markings.
For the display of status signals (time marking of significant events), you can choose between various symbols, 
such as a triangle, circle, square or cross. 

Filling gaps in signals

Missing measured values lead to gaps in the representation of time signals. You can decide whether the gaps 
shall remain or be filled with a line. 
You can fill the gaps in the time signals of instantaneous and r.m.s. values. 

Calculating signals

With SIGRA 4, you can define mathematical functions. These functions are used to generate calculated sig-
nals. The mathematical operators +, -, *, / and parentheses are available. 
As output signals for the calculation you can use the measuring signals as well as the signals calculated by 
SIGRA 4.

NOTE
The following chapters provide a more detailed description of the functions described here in brief.
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1.2 Cursors
SIGRA 4 features 2 cursors, cursor 1 and cursor 2. In the Time Signals view they are shown as vertical lines 
across all diagrams of the view. In the Circle Diagrams view they are displayed as crosshairs. 

The cursors are assigned to the time axis. If a cursor is moved in a view, its position in all other views is moved, 
too. 

Cursor color

The transparency of the fault record analysis is increased by the color coding of the cursor. The color assign-
ment can be found in the: 

• tables

• cursor symbol

• line or crosshair

• dialog boxes which refer to the cursor position.

Cursor position and table

When you move the cursors along the time axis, you can read the associated points in time and values of the 
assigned measuring signals from the table. 

Additionally, the following values are derived from the positions of the two cursors and displayed:

• sum and difference (using the same units)

• product and quotient (not for angles) 

For further information, please refer to paragraph 3.2.2. 

Behavior of the cursor lines

The behavior of the cursor lines can be determined via the menu item Options. Possible settings are: 

• Magnetic cursor lines

• Snap-in cursor lines

For further information, please refer to paragraph 3.2.3. 
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1.3 Time signals
The Time Signal view is used to display signals as a function of time.

DIGRA002.tif

Fig. 1-2 SIGRA 4, an example of the representation of time signals.

In this view, you can define any number of diagrams of the following types:

• status diagrams

• analog curve diagrams

• binary tracking diagrams

Each diagram can be assigned any number of measured and calculated variables, binary or status signals 
(time markings) and subsequently be dragged and dropped between the various diagrams. 

NOTE
In the default setting, SIGRA 4 assigns a separate diagram to each signal. 
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Instantaneous values / r.m.s. values

In the Time Signals view, you can choose to display the values as either instantaneous or r.m.s. values.

Status signals

In the status diagram, the trigger point for fault recording is displayed as a pre-defined status.
If you have selected User-defined status signals to mark the individual instants, they are displayed in the sta-
tus diagram with the selected symbol (see chapter 3.2.4).

Table

In addition to the graphical representation, you can read the values of individual signals at a defined instant in 
a table as well as the current positions of cursor 1 and cursor 2 on the time axis (see chapter 3.2.1 and 
chapter 3.2.2). Additionally, the following values are also derived from the cursors:

• Sum and difference (using the same units)

• product and ratio (not for angles)

The structure of the table can be freely configured in the View Properties dialog. The type of displayed values, 
such as r.m.s. values, instantaneous values, d.c. component or extreme value, etc., can be changed at any 
time (see chapter 4.2).

You can temporarily hide part or the whole of the on-screen display of the table (see chapter 3.2.7).

Tooltip

If you move the mouse pointer onto a signal of a diagram, a tooltip pops up which displays the signal name and 
value of the respective sampling instant. 

NOTE
If a cursor is shifted in another view, its position in the Time Signal view changes to correspond to that new 
position. 
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1.4 Vector diagrams
The vector diagram view is used to display measured and calculated variables at a defined instant in the 
form of complex vectors.

DIGRA003.tif

Fig. 1-3 SIGRA 4, an example of the representation of phasors in vector diagrams.

Here, the instantaneous values of the point in time at which the two cursors are currently located are displayed 
in 2 diagrams each.

The left-hand diagrams are permanently assigned to cursor, the right-hand diagrams to cursor 2. The bars 
in the cursor color above the diagram clearly show this assignment.

The vectors of the measured variables are r.m.s. values of the fundamental component 
(nominal frequency TN).
The absolute value and the angle of the vectors are determined by means of a full-cycle DFT (Discrete Fourier 
Transformation). 
The DFT measuring window is always placed to the left of the reference point (cursor position) and its 
length corresponds to one period of the nominal frequency TN (e.g. at 50 Hz this is 20 ms). 

With currents and voltages, the vector angle always refers to a standard vector ej2πfN (fN=nominal frequen-
cy) rotating at nominal frequency.

NOTE
The calculated variables are valid only if there is no status change (fault inception, tripping, gap in the meas-
ured value acquisition, etc.) within the measuring window!
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Phase position

Clicking the signal name zeros the phase position of this signal for the instant set by cursor 1. The values of all 
other signals are then aligned with this reference phase.

The changes also affect the representation of the signals in the Circle Diagram and Table views.

Table

In addition to the graphical representation, you can read the values of individual signals at defined instants in 
a Table and the current positions of cursor 1 and cursor 2 on the time axis (see chapter 3.2.1 and 
chapter 3.2.3).

The structure of the table can be freely configured in the View Properties dialog. The type of displayed values, 
such as absolute value, imaginary part or phase, etc., can be changed at any time (see chapter 4.2).

You can temporarily hide part or the whole of the on-screen display of the table (see chapter 3.2.3).

Tooltip

If you move the mouse pointer onto the arrow point of a diagram signal, a tooltip pops up which displays the 
signal name, value and phase position of the respective sampling instant. 

NOTE
If a cursor is shifted in another view, the vector diagram changes to reflect this shift. 
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1.5 Circle diagrams
The Circle Diagrams view visualises the change of complex variables as a circle diagram over time.

DIGRA007.tif

Fig. 1-4 SIGRA 4, an example of the representation of complex variables in circle diagrams.

Trip zones Distance protection

In addition to the positive-sequence impedances, circle diagrams can also display the trip zones of distance 
protection devices.

The characteristics are stored in the *.RIO/*.XRIO file.

Each trip zone is processed by SIGRA 4 as an impedance signal and can be assigned to any number of dia-
grams.

Table

In addition to the graphical representation, you can read the values of individual signals at defined instants in 
a Table and the current positions of cursor 1 and cursor 2 on the time axis (see chapter 3.2.1 and 
chapter 3.2.3).

The structure of the table can be freely configured freely in the View Properties dialog. The type of displayed 
values, such as absolute value, imaginary part or phase, etc., can be changed at any time (see chapter 4.2).

You can temporarily hide part or all ofthe on-screen display of the table (see chapter 3.2.3).
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Tooltip

If you move the mouse pointer onto a signal of the diagram, a tooltip pops up which displays the signal name 
and instant of the respective sampling instant. If you move the mouse pointer onto the trip characteristics of the 
distance protection (zone), a tooltip appears which displays the zone name and zone time of the protection de-
vice. 

NOTE
Cursor 1 and cursor 2 are displayed in this view as a small cross. If a signal is assigned to a cursor, the cursor 
changes to a crosshair of the same color as the cursor. 
The instant shown in the table corresponds to the respective intersection point. 
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1.6 Harmonics
The Harmonics view displays the r.m.s. values of the harmonics of selected measured variables in the form 
of bar charts.

DIGRA005.tif

Fig. 1-5 SIGRA 4, an example of the representation of harmonics as r.m.s. values.

The harmonics are determined by a full-cycle DFT (Discrete Fourier Transformation) depending on the instan-
taneous value at the position of cursor 1. The DFT measuring window is always situated on the left of the 
reference point (position of cursor 1) and its length corresponds to one period of the nominal frequency 
TN (e.g. at 50 Hz this is 20 ms).

If there is enough space, i.e. only one signal per diagram is defined, the r.m.s. value and the percentage value 
of the fundamental are displayed as bars If more than one signal is assigned, these values are displayed in 
the tooltip.

NOTE
The calculated variables are valid only if there is no status change (fault inception, tripping, gap in the meas-
ured value acquisition, etc.) within the measuring window. 
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Table

In addition to the graphical representation, you can read the values of individual signals at defined instants in 
a table and the corresponding position of cursor 1 on the time axis (see chapter 3.2.1 and chapter 3.2.3).

The structure of the table can be freely configured in the View Properties dialog. The type of displayed values, 
such as r.m.s. value, d.c. component or harmonic can be changed at any time (see chapter 4.2).

You can temporarily hide part or all ofthe on-screen display of the table (see chapter 3.2.3).

Tooltip

If you move the mouse pointer onto a signal of a diagram, a tooltip pops up which displays the signal name, 
value and frequency of the respective sampling instant. 

NOTE
High-frequency oscillating components and balanced components are usually damped by filters integrated in 
the protection devices. However, SIGRA 4 does not take these device-specific factors into acount. 
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1.7 Table
The table view displays the behavior of several signals at the same instant. The displayed values are the in-
stantaneous values at the position of cursors 1. To have the instantaneous values at other positions displayed, 
move cursor 1.

DIGRA004.tif

Fig. 1-6 SIGRA 4,  an example of the representation of values in table form.

The signals are arranged in rows, the individual columns contain the corresponding values, such as instanta-
neous value, r.m.s. value, phase, extreme value, etc. The column headings contain a short text. If you place 
the pointer over that text, a tooltip displays a more detailed text.

Phase position

Clicking the signal name zeros the phase position of this signal for the instant set by cursor 1. The values of all 
other signals are then aligned with this reference phase.

The changes also affect the representation of the signals in the Vector Diagram and Dircle Diagram views.

Sorting

If you want to sort the signals according to specific criteria (such as phase, absolute value, balanced compo-
nent), click on the column heading.
The order of the signals (rows) changes according to the values in the selected column (values within a signal 
group in ascending order).
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Configuration

You can configure the table rows in the Assign Signals view (see chapter 4.7).

Define the columns in the View Properties dialog (see chapter 4.2).

The configuration can be saved in the current user profile (see chapter 4.13). If the standard user profile is 
applied, the table configuration of the last evaluation session is used. 

NOTE
If there are no values in the table cells, the specifications are not physically defined. 
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2.1 General
SIGRA 4 is an application software which runs under Microsoft Windows and uses the windowing technique of 
these operating systems. To work with SIGRA 4, you need to have basic experience with these operating sys-
tems. 

For information on how to install/uninstall SIGRA 4 , please refer to the product information and Readme. 

Help system

SIGRA 4 provides a comprehensive help system:

• The general Help function can be called in any program level via the menu bar by clicking the Help Topics 
menu command. You can then look up information on individual topics. The chapters How to... offer stan-
dard methods of procedure for solving common tasks, such as "How to Define Your Fault Record Set-
tings".

• Press F1 for Help information on the menu commands.

• Click the Help button in the dialog boxes to obtain further information on the parameters of the selected 
dialog box.

2.2 Starting SIGRA 4
To start SIGRA 4 from the Windows desktop, proceed as follows:

✧ Click the Start button in the Windows taskbar and select Siemens Energy > SIGRA 4 > SIGRA 4 from 
the start menu.

SIGRA 4 is started in the installation language.

✧ Now, load your fault record by selecting the File > Open menu command and start your analysis.

Alternatively, SIGRA 4 can be opened by double-clicking the .CFG file of a fault record. 

Please refer to chapter 3.2 for further information on fault records settings.
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2.3 Operation

2.3.1 Controls
You can operate SIGRA 4 by:

• selecting a menu command from the menu bar

• selecting a button from the toolbar

• selecting a context-sensitive function from the context menu

Menu bar

All the SIGRA 4 functions can be accessed via the menu bar. 

✧ Click a menu command, such as View. From the drop-down menu, select the required function, such as 
Primary Values.

Toolbars

Certain selection functions and the edit functions common to all Windows programs, such as Save, Copy, etc. 
can be found under the Standard and View toolbars.

SIGRA103.tif

Fig. 2-1 SIGRA 4, Standard toolbar

SIGRA102.tif

Fig. 2-2 SIGRA 4, View toolbar

The meanings of the individual buttons are explained in Table 2-1 in chapter 2.7.

NOTE
If you press the F1 key while your mouse is positioned on a function of the pull-down list, a Help page with a 
brief explanation of this function appears. 
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Context menus

In SIGRA 4 the user is guided mainly by context-sensitive menus. You can use these menus, for example, to 
switch to the next dialog box, to activate copy functions, to insert diagrams or to maximize the screen display.
SIGRA 4 always offers only the functions currently admissible in this context for selection.

To do this, proceed as follows:

✧ Move your mouse pointer to the object to be edited (multiple selection is possible);

✧ press your right mouse button. The relevant context menu appears;

✧ click the function you wish to be executed.

DIGRA031.tif

Fig. 2-3 SIGRA 4, an example of a context menu.

NOTE
We recommend the use of context menus for the selection of operator functions. 
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2.3.2 Copy / Paste / Cut
SIGRA 4 offers a range of convenient editing functions which help you to structure your fault record clearly and 
quickly. You can also use these functions to export data, such as diagrams or tables, to other applications such 
as Word, Excel or PowerPoint. When working in SIGRA 4, you can also use the drag-and-drop function and 
the Clipboard for fast assignment of signals to diagrams and tables, or of diagrams to the views.

The functions

• Copy

• Paste

• Cut

can be performed using the drag-and-drop technique, the context menu, the toolbar or the menu bar.

Duplicate objects, such as diagrams or signals, using the convenient drag-and-drop technique or the Copy and 
Paste commands. The object, including all parameters, is then duplicated.

For further information on these procedures, please refer to chapter 4.3 Inserting diagrams to chapter 4.8. 
Copying signals.
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2.4 Displaying different views
You can display the SIGRA 4 views on the screen next to one another or in windows which overlap .

Switching views

If the selected view covers the whole screen, you can switch to another view, such as the Vector Diagrams 
view, as follows:

✧ Select View > Vector Diagrams from the menu bar;

or

✧ click the Vector Diagrams buttonin the Toolbar (see chapter 2.7).

The selected view type appears.

Displaying multiple views

If you would like to display more than one view on the screen at the same time, proceed as follows:

✧ First select all the views you want displayed;

✧ select a menu item from the Window > e.g. Tile Horizontally from the menu bar.

In this case, the views are arranged in separate windows on the screen so that they fit next to one another.

✧ You can now change the size of the individual windows.

Optimizing the window arrangement

To make optimum use of free spaces between the individual windows: 

✧ In the upper right-hand window, click on the Cascade button.

SIGRA 4 increases the size of the window so that the available space is optimally used in all directions.

If you select a further view, SIGRA 4 places it in the available gap and makes it the maximum size possible.

If the window cannot be optimized, the button in the window is grayed.

Changing the size of a table

In the Time Signals, Vector Diagrams, Circle Diagrams and Harmonics views, a table appears for the dis-
play of selected measured or calculated variables.
If you want to temporarily hide or reduce the on-screen display of the table, proceed as follows:

✧ Move the mouse pointer to the lower border of the table.

The mouse pointer changes.

✧ Keep the left mouse button pressed and drag the border towards the top of the screen;

✧ drag the border back down to make part or the whole of the table visible again.
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2.5 Changing the value display
In SIGRA 4 you can choose different values for the display of measured and calculated variables of your fault 
record.

2.5.1 Primary values / secondary values
SIGRA 4 lets you represent the values of a fault record in the views as primary or secondary values.

Primary values

✧ Select View > Primary Values to display the primary values with reference to the nominal transformer 
values of the signals.

Secondary values

✧ Select View > Secondary Values to display the secondary values with reference to the nominal 
transformer values of the signals.

2.5.2 R.M.S. values / instantaneous values
The Vector Diagrams, Circle Diagrams and Harmonics views always display r.m.s. values. In the Time Sig-
nals view, you can also display diagrams with the instantaneous values.

R.M.S. values

✧ Select View > R.M.S. Values from the menu bar to display the signals as R.M.S. values.

Instantaneous values

✧ Select View > Instantaneous Values from the menu bar to display the signals as instantaneous values.

The other views are not affected by this selection. 

NOTE
You can specify which variables of the signals you want displayed in the Table view in the View Properties 
dialog. 
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DIGRA049.tif

Fig. 2-4 SIGRA 4, representation of time signals via instantaneous values.
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DIGRA002.tif

Fig. 2-5 SIGRA 4, representation of time signals via r.m.s. values.
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2.6 Zooming
If you wish to change the diagram scale interactively, SIGRA 4 offers some convenient zoom functions.

When the zoom mode is activated, the mouse pointer changes, depending on its position in the views.
The symbols represent the various functions.

2.6.1 Activating the Zoom Mode
You can activate the Zoom mode either:

• by selecting View > Zoom > Zoom from the menu bar, or

• by clicking the Zoom In/Out button in the toolbar (see chapter 2.7)

• by choosing Zoom from the context menu.

When activating the zoom function, the mouse pointer symbol changes its shape to a magnifying glass.
With this function, you can maximize any section of a diagram.

2.6.2 Maximize / Minimize

Maximizing a section

✧ Position the magnifying glass on the upper left-hand corner of the section to be enlarged while keeping 
the left mouse button depressed. Draw a frame over the whole area you wish to maximize and release the 
mouse button.
The section marked is enlarged.

✧ Repeat this procedure until the display has reached the size you want.

Changing the axis scale

If you approach one of the axes with the magnifying glass, you can change the axis scale as follows:

Use the left mouse button (+) to increase, or the right mouse button (–) to decrease the axis scale along the X- 
or Y-axis.

In the Vector Diagrams view, you can enlarge or reduce the display size of the individual vectors (voltages or 
currents) separately.

✧ Click one of the scales in the corners of the diagram with the magnifying glass.

Depending on its position, the magnifying glass changes as follows:
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Upper right-hand corner of the vector diagram
Use the left mouse button (+) to increase, or the right mouse button (–) to decrease the scale

Upper left-hand corner of the vector diagram
Use the left mouse button (+) to increase, or the right mouse button (–) to decrease the scale

Lower right-hand corner of the vector diagram
Use the left mouse button (+) to increase, or the right mouse button (–) to decrease the scale

Lower left-hand corner of the vector diagram
Use the left mouse button (+) to increase, or the right mouse button (–) to decrease the scale

If you position the magnifying glass within the circle, you can change the 
display size of all vectors.
Use the left mouse button (+) to increase, or the right mouse button (–) to decrease the scale.

NOTE
In the Circle Diagrams view, the representation is conformal. This may mean that the displayed area is larger 
than the value specified. 
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2.6.3 Optimizing
In addition to the zoom functions described above, you can also optimize the diagram scale with SIGRA 4.

DIGRA040.tif

Fig. 2-6 SIGRA 4, optimizing the representation of the diagrams.

Proceed as follows:

✧ Select all diagrams to be displayed at maximum size in the selected view;

✧ select Zoom > Optimize from the context menu or 
View > Zoom > Optimize from the menu bar.

The X-axis and the Y-axis scales are optimized. 

Optimize X-Axis

✧ Select Zoom > Optimize X-Axis from the context menu or
View > Zoom > Optimize X-Axis from the menu bar.

The scale of the time axis of all diagrams in a view is optimized, the Y-axis scale remains unchanged.

NOTE
SIGRA 4 chooses the maximum scale actually possible for the display of currents and voltages; in the case of 
impedances it chooses the “ideal” display, since the maximum of these variables is infinite. 
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Optimize Y-Axis

✧ Select all diagrams to be displayed at maximum size along the Y-axis in the selected view;

✧ select Zoom > Optimize Y-Axis from the context menu or
View > Zoom > Optimize Y-Axis from the menu bar.

The Y-axis scale is optimized, the X-axis scale remains unchanged.

2.6.4 Matching
You can use the Match zoom function to achieve a uniform scale of several diagrams displayed in one view.

✧ Select all the diagrams whose scale is to be matched.

✧ Set the focus on the master diagram (broken line around the diagram last marked).

✧ Select Zoom > Match from the context menu or
View > Zoom > Match from the menu bar.

The scale of the selected diagrams (along the Y-axis) is matched to the scale of the diagram you have defined 
as the “master diagram”.

NOTE
Due to the circular arrangement, X-axis and Y-axis optimization does not affect the vector diagrams. 
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2.7 Toolbar buttons
The following table lists all the buttons and their respective functions of the SIGRA 4 Standard and View tool-
bars.

Table 2-1 SIGRA 4 toolbar buttons

Button Function/Meaning

Opens a file

Saves a file

Prints the current selection

Deletes the selected objects and places them on the Clipboard

Copies the selected objects onto the Clipboard

Pastes objects from the Clipboard

Fills gaps in the signals

Displays the Assign Signals matrix

Displays the Time Signals view

Displays the Vector Diagrams view

Displays the Circle Diagrams view
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Displays the Harmonics view

Displays the Table view

Displays the Fault Locator view

Shifting the display area, activate/deactivate

Activates/deactivates zoom mode

Changes the diagram height

Displays primary values

Displays secondary values

Displays instantaneous values

Displays r.m.s. values

Selects the Network Configuration dialog

Table 2-1 SIGRA 4 toolbar buttons

Button Function/Meaning
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Assigns the network configuration

Selects the User Profile dialog

Assigns the user profile

Table 2-1 SIGRA 4 toolbar buttons

Button Function/Meaning
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2.8 Changing the language
The language can be changed via the SIGRA 4 menu, for example during commissioning to the mother tongue 
of the service staff. 

When the language is changed, opened fault records are closed and any changes made get lost. A correspond-
ing warning is displayed. Therefore, save all fault records before changing the language. 

How to change the language: 

✧ Save opened fault records if you have made any changes and these are not to get lost. 

✧ Select the desired language in the menu via Tools > Language. 
The Change Language dialog is opened. 

✧ Close the dialog by clicking Yes.
All opened fault records are closed. The language is changed. 

NOTE
The language for SIGRA 4 can be set upon startup with a command line via a parameter. The available lan-
guages and associated parameters are the following:

• German = /a

• English = /b

• French = /c

• Spanish = /d

• Italian = /e

• Russian = /f

• Chinese = /k

• Turkish = /l 
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3.1 General
Fault records to be analyzed by SIGRA 4 must be available in COMTRADE format. To this end, the fault 
records of the SIPROTEC 4 device series can be retrieved from the devices using the DIGSI 4 parameteriza-
tion software and stored in COMTRADE format. These can then be processed directly by SIGRA 4 without any 
further modification.

For the analysis of these fault records, SIGRA 4 uses the values measured to calculate further variables, such 
as impedances and outputs, and processes all measured and calculated variables and the associated binary 
signals for graphical display. The signals are displayed in the Time Signals, Vector Diagrams, Circle Diagrams, 
Harmonics and Table views (see chapter 1.3 to chapter 1.7).

You can freely adapt the representation of a fault record to suit your operating requirements and define your 
own settings with regard to the distribution of signals in the Table view and the individual diagrams. Dialogs are 
also available for specifying colors, labeling, diagram size, etc. You can save these individual parameter set-
tings in the user profiles for analysis of further fault records. Each fault record can be permanently or tempo-
rarily assigned one of these individually defined user profiles via the toolbar (see chapter 4.13).

In the case of fault records of devices which do not belong to the SIPROTEC system range, the recorded mea-
sured variables must be adapted to suit SIGRA 4 conventions (see chapter 5 Reference arrow definition, 
Calculations).

You can establish compatibility of the data of these devices recorded in the fault record to SIGRA 4 via the 
Network Configuration and Signal Properties - Analog Signals dialogs (see chapter 3.10 and
chapter 4.10).

Fault record files

A fault record is made up of several files which are stored under one name but with the following extensions:

*.CFG COMTRADE configuration file
Description of the fault record channels (signal name, sampling rate, etc.). Generated (for example) 
by DIGSI 4.

*.DAT COMTRADE file
Sampling values of the fault record channels (measured variables). 
Generated (for example) by DIGSI 4.

*.RIO Available as an option 
protection settings (such as earth impedance factors).
Generated (for example) by DIGSI 4.

*.DG4 Available as an option
Contains SIGRA 4-specific settings related to a fault, such as cursor positions, color settings, etc., 
of the last evaluation session (session memory).
Generated by SIGRA 4 when a file is saved.

*.HDR Available as an option
Comment on the fault record

*.INF Available as an option
Any comment on an individual signal.

NOTE
These files must be saved or moved together. 
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3.2 Fault record settings

Table

In addition to the graphical representation of the signals in the diagrams, the Time Signals, Vector Diagrams, 
Circle Diagrams and Harmonics views contain a table where you can directly read the absolute value of in-
dividual signals at different instants. You can freely configure which measured or calculated variables of the 
signals are to be displayed
(see chapter 4.2).

DIGRA134.tif

Fig. 3-1 SIGRA 4,  an example of the representation of time signals in table form.

If you want to know the exact value of a particular measured or calculated variable at a defined instant, you can

• assign this signal to a cursor (see chapter 3.2.1) and

• set the cursor to this instant (see chapter 3.2.2).

Signal names, values and the instant are shown in the table. 

Tooltip

If you move the mouse pointer onto a signal of a diagram, a tooltip pops up which displays the sampling instant 
signal name, value(s) and instant.

Zoom

To improve analysis accuracy, change the resolution of the signal display in the diagrams quickly and conve-
niently using the Zoom functions (see chapter 2.6).

Markers / status signals

Marking the signals' sampling instants (see chapter 3.2.4) and the time marking of events by means of 
status signals (see chapter 3.2.5) also helps you to effectively analyze the fault record.

NOTE
Only cursor 1 is used in the Harmonics view.

The Table view does not contain any diagrams. The signals configured for the table (see chapter 4.7) are per-
manently assigned to cursor 1. 
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3.2.1 Assigning measured signals
This table lets you assign the significant signals required for fault record analysis.

SIGRA135.tif

Fig. 3-2 SIGRA 4, an example of the representation of vector diagrams in table form.

✧ Click the Measuring Signal box of Cursor 1 and select a signal from the drop-down list, e.g. VL1;

✧ click the Measuring Signal box of Cursor 2 and select a signal from the drop-down list, e.g. VL2.

The cursor position on the time axis is displayed in the t in ms box.
The other boxes display the respective values of the signal at this instant.

Meaning of the lines:

• C2 - C1
This line shows the difference (time and values) calculated by SIGRA 4.

• C2 + C1
This line shows the sum (values) calculated by SIGRA 4.

• C2 / C1
This line shows the quotient (values) calculated by SIGRA 4.

• C2 * C1
This line shows the product (values) calculated by SIGRA 4.
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3.2.2 Assigning instants

Cursor 1 / Cursor 2

The current cursor position on the time axis is shown in the tables of all views.

In the Time Signals view, the cursors are also displayed by a vertical line across all diagrams, in the Circle Di-
agrams view they are represented as a small crosshair or, if a measured signal has been assigned, as a large 
crosshair. 
The cursors are color-coded. The color assignment can be found in the cursor symbol, line or crosshair, the 
tables and in the dialog boxes.

Only cursor 1 is used for measuring in the Harmonics view.

Positioning the cursor

To position a cursor at a defined instant, proceed as follows:

✧ Click the cursor symbol and keep the left mouse button pressed. Move the cursor along the time axis to 
the left or the right. You can follow the positioning along the time axis in the t in ms box of the table. 
Release the mouse button when you have reached the desired point;

or

✧ enter the instant in the t in ms box of the table.
SIGRA 4 then sets the cursor automatically to this instant;

or

✧ click the t in ms box and increase / decrease the value using the
up / down arrows.
SIGRA 4 then shifts the cursor automatically to this point.

NOTE
The measuring window for calculation is always situated on the left of the reference point (cursor position). 
The length of the measuring window corresponds to one period of the nominal frequency TN which is, for ex-
ample, 20 ms at 50 Hz. 

The calculated variables are valid only if there is no status change (such as fault occurrence or disconnec-
tion) within the measuring window. 
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In the Circle Diagrams view, you can also position the cursor at a defined sampling instant as follows:

✧ Assign a signal to the cursor.
The cursor is displayed as a large crosshair;

✧ spproach the intersection of the cursor lines with your mouse pointer. The mouse pointer changes to a 
hand symbol. Keep the left mouse button pressed and move the hand to the required sampling instant.

3.2.3 Determining cursor behavior

Magnetic cursor lines

With the Options > Magnetic Cursor Lines menu command you can synchronize the movement of a cursor 
along the time axis quickly and exactly with:

• status changes of binary signals and

• status signals (marking of significant instants)

When a cursor approaches such an event, it is attracted “magnetically” and "snaps" to that point.

If you have also activated the Snapping Cursor Lines function, you can move the cursor to this event by jump-
ing from one sampling instant to the next.

Snap-in cursor lines

With the menu command Options > Snapping Cursor Lines you can synchronize the movement of a cursor 
along the time axis with the sampling instants of the signals.

If you have also activated the Magnetic Cursor Lines function, when the cursor approaches a status change 
or a status signal, it is attracted “magnetically” to this event and "snaps" to that point.

NOTE
For easier identification of the individual sampling instants, we recommend marking the signal you want to 
measure via the Object Properties dialog. Each sampling instant is then marked by a symbol 
(triangle, circle, etc.) (see chapter 3.2.4). 

NOTE
If both functions are deactivated, you can move the cursor continuously along the time axis. 
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3.2.4 Placing markers
When analyzing a fault record, it is often useful to highlight signals by means of graphical symbols. These 
markers are placed at the signal sampling instants. This function makes it considerably easier to position 
the cursor at defined instants, particularly when evaluating circle diagrams (see chapter 3.2.2).

To place the markers for analog signals in the Signal Properties dialog box, proceed as follows:

✧ Double-click the signal in the diagram legend,

or

✧ select the signal you want to mark in the diagram legend and open the corresponding dialog box by 
choosing Object Properties from the context menu or selecting Edit > Object Properties from the menu 
bar;

or

✧ select the Signal Properties dialog from the Assign Signals dialog box. To do this, right-click the Signal 
name or Signal line column and select Properties from the context menu;

dirgra048.tif

Fig. 3-3 SIGRA 4, editing the signal properties of analog signals.

NOTE
If you are only displaying a single signal in a diagram, select the Signal Properties dialog by double-clicking 
the signal name on the axis labeling. 
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✧ select the symbols you want to mark from the Marker type drop-down list.
You can see the parameterized signal display in the preview section;

✧ confirm with Apply if you want to mark further signals. Select the next signal from the signal list and repeat 
the marking procedure;

✧ confirm your input with OK.

NOTE
The selected marking is applied to the signal in all diagrams in which it is displayed, as well as the legends 
(not in the axis labeling).
Markers do not apply to vector diagrams. 
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3.2.5 Inserting status signals
In order to time mark significant events, you can define your individual Status signals in the Time Signal view.

The trigger point for fault recording is marked automatically by SIGRA 4 with a status signal (trigger).

✧ Select the status diagram in which you want to insert the status signal (multiple selection is possible);

✧ position cursor 1 on the instant you want to select;

✧ insert a new status signal by selecting Insert > Status Signal from the menu bar and define the Signal 
Properties in the corresponding dialog box.

DIGRA041.tif

Fig. 3-4 SIGRA 4, inserting a status signal into a diagram.

In the Signal list box you can see the names of all signals available.

The status signal inserted appears as New Status Signal and is highlighted.

✧ Rename the status signal identified as New Status Signal in the Name text box;

✧ select the desired Line style from the drop-down list where the different types of line display are provided, 
e.g. line, dots, dot-and-dash, etc.;

✧ use this box to enter the Line weight of a signal as an absolute number of pixels or by increasing/
decreasing the value using the up/down arrows;

✧ select the symbol to be used for the status signal in the status diagram of the Time Signal view from the 
Marker type drop-down list;

✧ click the Color button and switch to the next dialog box where you can select a color or define a new 
shade.

The Instant text box shows the position of cursor 1.

✧ If necessary, you can correct the value in the Instant text box.
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In the Preview section, you can see how the current settings affect the signal display in the status diagram.

✧ Confirm your input with OK.

The status signal is displayed in the status diagrams selected.

If no status diagram has been selected, SIGRA 4 opens the Assign Signals dialog box automatically.

✧ Assign the signal to all diagrams where you want it to be displayed (see chapter 4.7).

3.2.6 Deleting Status Signals
To delete a status signal, proceed as follows:

✧ Select the status signal in the status diagram or in the Assign Signals matrix. Delete the signal by 
selecting Delete from the context menu, by selecting Edit > Delete from the menu bar or by clicking the 
button in the toolbar.

The status signal is deleted from the display. 

3.2.7 Hide/Show table
If you do not need to display the values of individual signals in a view in table form, you can reduce or hide 
the table.

To do this, proceed as follows:

✧ Move the mouse pointer to the lower border of the table.

The mouse pointer changes.

Hide

✧ Keep the left mouse button pressed and drag the border towards the top of the screen.

Show

✧ Drag the border back down to make part or the whole of the table visible again.

NOTE
If you delete a user-defined status signal from the last display used, it is also removed in the SIGRA 4 manage-
ment.
The status signal, which marks the trigger point for fault record recording, can only be deleted from the display. 
However, it is still in the Assign Signals matrix. 
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3.3 Inserting a fault record
If you need an additional fault record for the analysis of a fault event, such as that from the remote side of a 
line, you can insert the diagrams of this fault record at the end of the selected view.
The selected signals of the fault record are displayed in these diagrams. 

Proceed as follows:

✧ Select Insert > Fault Record from the menu bar;

✧ specify the name and storage location (path) of the fault record you want to insert.

The signal names of the fault record inserted are extended by an index, e.g. IL1_1.

Since recording devices at different installation locations are not usually synchronized, the signals of the two 
fault records must be synchronized to ensure correct evaluation.

NOTE
The fault record must be available in COMTRADE format! 
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3.4 Synchronizing fault records
When synchronizing the signals of the inserted fault record (B) with the fault record to be analyzed (A), SIGRA 4 
shifts the signals of the inserted fault record along the time axis by a defined interval.

To do this, proceed as follows:

✧ Insert a new diagram in the time signal view (see chapter 4.3);

✧ copy a corresponding signal from fault record A, such as the conductor current affected by a short-circuit, 
and insert it in the new diagram (see chapter 4.8);

✧ copy a corresponding signal from fault record B and insert it in the diagram as well;

✧ if necessary, enlarge the display using the zoom functions (see chapter 2.6);

✧ position cursor 1 on the synchronization point of the signal of fault record A (e.g. point of fault 
occurrence) and cursor 2 on the synchronization point of the signal of fault record B;

✧ open the corresponding dialog box by selecting Edit > Synchronize Fault Records from the menu bar;

✧ check the synchronization points and shift interval in the text box Shift fault record B by;

✧ check the settings using the Preview function;

✧ adjust the synchronization points if necessary;

✧ confirm your settings with OK.

The signals of fault record B are shifted by the calculated interval.
The two fault records can now be evaluated together.

✧ If necessary, repeat the described steps to fine-tune the synchronization.

NOTE
The color-coding of the cursor is useful when setting the synchronization points. The synchronization points in 
the dialog box are identified by the corresponding cursor color. 

NOTE
If a bidirectional fault location was carried out, the dialog Synchronize Fault Records cannot be selected be-
cause in this case the fault records were synchronized automatically. 
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DIGRA042.tif

Fig. 3-5 SIGRA 4, synchronizing the signals of two fault records.

In addition to the procedures described above, you may also synchronize the shift interval directly or perform 
fine tuning using the Synchronize Fault Records dialog box.

To do this, proceed as follows:

The Fault record A box shows the name of the fault record to be used as the master for synchronization. The 
name in this text box cannot be changed.

✧ Select the name of the inserted fault record to be synchronized from the drop-down list in the 
Fault record B box.

In this section, you initially see the values of the current position of cursor 1 and cursor 2 which have been set 
to their synchronization points in the diagram.

✧ Enter the significant instant in the Synchronization point fault record B (cursor 2) box;

✧ enter the shift interval for fault record B in the Shift fault record B by box using the spinbuttons. A preview 
of the synchronization is generated automatically;

✧ confirm your settings with OK.
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3.5 Editing fault records
If you want to add or delete a fault record previously inserted during fault record analysis, proceed as follows:

✧ Open the corresponding dialog box using the Edit > Fault Record... menu commands;

DIGRA043.tif

Fig. 3-6 SIGRA, adding or deleting a fault record.

✧ select the fault record you want to edit;

✧ select the Add button if you require the data of a further fault record;

✧ in the next dialog box Open, select the fault record (directory path);

✧ in the Edit Fault Record dialog box, enter the additional index for the signal name of the inserted fault 
record;

✧ confirm your settings with OK;

or

✧ if you no longer need the data of an inserted fault record, select the Delete button;

✧ confirm with OK.

NOTE
When using this dialog box, the fault record is deleted only in the SIGRA 4 data management. 
58 SIPROTEC, SIGRA 4, Manual
E50417-H1176-C070-A6, Edition 02.2011

http://siemens-russia.com/


Fault records

3.6 Adding comments to a fault record

SIGRA_MANUAL_A6_EN.book  Page 59  Monday, February 21, 2011  8:08 AM
3.6 Adding comments to a fault record
SIGRA 4 allows you to add own comments, e.g. evaluation results. You may add comments to: 

• the fault record 
This comment is displayed in an own text field under Comment and stored in the fault record file *.HDR. 

• an individual signal
This comment is displayed in the diagram and stored in the *.INF file. 

Commenting a fault record

To do this, proceed as follows:

✧ Select Edit > Comment... from the menu bar;

DIGRA200.tif

Fig. 3-7 SIGRA 4, an example of a fault record comment. 

✧ type your comment in the Edit Comment dialog box;

✧ confirm your settings with OK.
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Commenting a signal

Comments assigned to a signal can be added in the views Time Signals and Circle Diagrams. It is not pos-
sible to assign a comment to the signal of an r.m.s. value. 

The following can be done with a comment:

• Add

• Edit

• Hide

• Delete

The functions are called via a context menu. 

It is possible to add several comments to each signal. If you add the commented signal to another diagram, the 
comments are shown there, too. 

The zoom function has no effect on the comment. 

To add a comment to a signal, proceed as follows:

✧ Right-click the signal you want to comment. 
The comment will later be added at the position on which you click. 

SIGRA046.tif

Fig. 3-8 SIGRA 4, adding a comment to a signal. 

✧ From the context menu, select Add Comment. 
The Add Comment dialog is opened. 
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SIGRA047.tif

Fig. 3-9 SIGRA 4, editing the comment. 

✧ Enter the comment in the text input field and close the dialog with OK. 
The comment is added to the diagram at the desired position. 

SIGRA048.tif

Fig. 3-10 SIGRA 4, the diagram with the added comment. 
61SIPROTEC, SIGRA 4, Manual
E50417-H1176-C070-A6, Edition 02.2011

http://siemens-russia.com/


Fault records

3.7 Filling gaps in signals

SIGRA_MANUAL_A6_EN.book  Page 62  Monday, February 21, 2011  8:08 AM
3.7 Filling gaps in signals
Missing measured values, i.e. information gaps in the fault record data, are shown as gaps in the signal repre-
sentations. Nevertheless, it is possible to fill these gaps with values in order to achieve a continuous curve 
progression.

You can fill the gaps in the time signals of instantaneous and r.m.s. values. 

You can decide whether the gaps are to be shown or filled with values. A fault record in which signal information 
is missing is shown with gaps after opening. 
In the representation of r.m.s. values the gaps are larger than in the representation of instantaneous values 
because an r.m.s. value is calculated from the entire preceding period. Therefore, in the case of r.m.s. values 
the entire period is shown as a gap to prevent any misinterpretation due to the missing data.

SIGRA065.tif

Fig. 3-11 SIGRA 4, the time signals contain gaps. 

To toggle between the representations with and without gaps, proceed as follows:

✧ Go to the Time Signals view. 

✧ From the menu, select Edit > Fill Signal Gaps. 
The gaps in the signals are filled with values. 

SIGRA066.tif

Fig. 3-12 SIGRA 4, the missing signal information is filled with values. 

A checkmark is displayed before the menu item Fill Signal Gaps. 

✧ To have the signal shown with gaps again, select Edit > Fill Signal Gaps from the menu again. 

The option Fill Signal Gaps has effects on the following functions:

• Save

• Save as 

• COMTRADE Export

These functions save/export the signals the way they are currently shown. If the option Fill Signal Gaps is ac-
tivated, the signals are saved/exported with the fillers. 
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3.8 Printing fault records
You can print either the complete fault record or selected diagrams of a view.

Proceed as follows:

✧ Open the Print dialog box by selecting File > Print from the menu bar;

✧ specify the printer settings, such as type of printer, printer options (paper size, etc.), print area (complete 
fault record or selected areas) and the number of copies to be printed;

✧ confirm your settings with OK.

If you choose to print to a file, you are prompted for the name and storage location (path) of the target file.

NOTE
If using a monochrome printer, it may be useful to change the fault record layout for printing in order to be able 
to identify the different signals, e.g. by using different line styles (broken line, dotted line, etc.).

Define a specific layout for the printer and save this as a user profile. Assign this user profile before printing. 
For further details refer to chapter 4.13. 
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3.9 Exporting fault records
In the course of evaluating a fault, it may be necessary to further process the data of a fault record. All data of 
a fault record processed by SIGRA 4 can be exported. This means that, in addition to the variables recorded 
in the fault record, all calculated variables, such as impedances or outputs, are also available.

The following options are available for exporting data:

• Export to a file in COMTRADE format

• Export to other applications, such as Excel, Word, PowerPoint, etc.

3.9.1 COMTRADE Export
To export in COMTRADE format, proceed as follows:

✧ Open the COMTRADE-Export dialog box by selecting File > COMTRADE Export from the menu bar;

DIGRA201.tif

Fig. 3-13 SIGRA 4, an example of the COMTRADE export of a fault record.
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✧ enter the relevant data of the fault record in the Station name, Sampling rate and Nominal frequency 
fields;

✧ select the data format in the DAT Format section and the standard according to which you want to store 
the data in the CFG Format section.

If you select the option Old under CFG Format, the fault record is stored in the COMTRADE 91 format. If you 
select the option New, the fault record is stored in the COMTRADE 99 format.

Specify the signals you want to export in the Channels section.

✧ To do this select all the relevant channels in the Not Contained box (multiple-selection possible) and click 
the double arrow pointing to the right.

The signals are placed in the Contained box.

✧ Check your selection and return any signals not required to the Not Contained box by clicking the double 
arrow pointing to the left;

✧ click the Save button and enter the file name and storage location (path) of the fault record in the 
subsequent Save As dialog.

NOTE
In the COMTRADE export the signals are resampled at the selected sampling rate. 
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3.9.2 Documentation of results
Analysis results can be documented very simply with other programs. The transfer of data to other programs 
is done in a very simple way:

• using the drag-and-drop function or

• transferring to and from the Clipboard using the Copy and Paste commands

These operations allow you to transfer tables or diagrams to office applications, such as Word or Excel.

Proceed as follows:

✧ Open the application.

✧ In SIGRA 4, select the data you want to export (multiple-selection possible).

✧ Hold the left mouse button and drag the selected area to your target position in the application 
(drag-and-drop).

or

✧ Select the Copy command via the context menu, the toolbar button or the Edit menu and then select the 
Paste command in the target application.

NOTE
By dragging and dropping the diagrams, you can adjust the diagram size in SIGRA 4 to the size you require in 
the target application. This improves the image quality as there is no need for further processing. 

NOTE
If, for example, you copy a SIGRA 4 table to a Word document, the Convert Text to Table menu command in 
Word quickly and conveniently converts the inserted data to a Word table. 
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3.10 Parameterizing fault records
SIGRA 4 can process all fault records that are available in the COMTRADE format.
The conventions used under SIGRA 4 for the evaluation of fault records and calculation of further variables are 
designed for fault records generated by DIGSI 4 (see chapter 5 Calculations / Definitions).

If you wish to evaluate fault records from other programs, the parameter settings of these records may need to 
be adapted.

Use the Network Configuration dialog to assign the physical meaning of the measured variables and specify 
the factors for the calculation of the positive-sequence impedances.
By saving a network configuration you can save assignments that you have made and open them again sub-
sequently. 

Via the Settings dialog you define the source of the network frequency and the settings for the impedance cal-
culation. 
Via the Signal Properties dialog, Analog Signals tab, you define the transformer data and type of values re-
corded in the fault record (primary or secondary values).

NOTE
This procedure is not required for fault records from SIPROTEC 4 devices! 
However, you can also use the Network Configuration dialog to specify the impedance calculation for these 
devices by modifying the protection settings written to the fault record file by DIGSI 4 or higher. 
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3.10.1 Parameterizing network configuration
You can assign the physical meaning of the signals collected in a fault record under the Signal Assignment 
tab. This assigns the SIGRA 4 reference arrow definition to the currents and voltages of the SIGRA 4 network 
node (see chapter 5.3).

Fault records of SIPROTEC 4 devices only require the parameterization of the fault locator in the Fault Locator 
tab.

Using the Configuration function you can save a new network configuration and open it again subsequently. 
To save a configuration, click on the Add button after having entered the network configuration details, give the 
configuration a name and then save the data. It can be opened again later via the toolbar. The network config-
uration includes the channel assignment as well as the line data used for locating a fault.

SIGRA 4 manages up to twelve different network nodes. You can assign these network nodes any name. The 
default settings for the node names are K1 to K12. If signals are assigned to more than one network node, 
SIGRA 4 prefixes these signal names with the network node names followed by a colon, e.g. K1:VL1E.

It is possible to assign the same signal to several network nodes.

✧ Open the dialog box by selecting the Options > Network configuration... from the menu bar.

SIGRA203.tif

Fig. 3-14 SIGRA 4, configuring the assignment of the recorded signals. 
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✧ Select the current network configuration from the Configuration drop-down list. Using this parameter you 
can save settings for various configurations and use them again subsequently.

− Klick on Add to assign a name to a new configuration.

− Select a configuration and click on Delete to delete the configuration.

✧ Type a name in the Network Nodes box (either directly or using the arrow keys). 

✧ Activate Save Signal Assignment to save the set signal assignment. 
The signal assignment is saved for all nodes in the network configuration file. 

✧ Use the Signal Assignment tab to assign the signals of your fault record to the network node according 
to their physical meaning. 

✧ Select the earth current of the node at IE, if available. 
If None is selected, the earth current is calculated from the 3 phase currents. 

✧ If the earth current is selected at IE, the transformation ratio of IE has to be adjusted to that of the phase 
current transformers at IE/Iph. 
IE/Iph = transformation ratio earth current transformer/transformation ratio phase current transformer

For the conversion between primary and secondary values, the transformer data are required. If the fault record 
does not contain any transformer data, as is the case with, for example, fault records in COMTRADE91 format, 
the correct nominal transformer data can be entered in the Nominal field. 

✧ Enter the transformation ratios of the current and voltage transformers in the Nominal field.

NOTE
Do not activate the Save Signal Assignment option if several devices are located at the nodes of this config-
uration. In this case it is much more simple to apply this network configuration to the fault records of the various 
devices. 
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Parameterizing the fault locator

✧ Change to the Fault Locator tab.

SIGRA204.tif

Fig. 3-15 SIGRA 4, making the fault locator settings.

✧ To specify the format for the operating data of the transmission line in the Input Format dialog, click on 
Input format....

SIGRA204b.tif

Fig. 3-16 SIGRA 4, defining the input format for the fault locator.

✧ Confirm your settings with OK.
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✧ If you want to carry out bidirectional fault location then specify the Network node at the opposite line 
end.

✧ Define the line section properties in the table:

For details on the earth impedances and coupling factors, please refer to paragraph 5.9.

A maximum of 10 line sections can be parameterized:

✧ Click on Add section to insert the parameter table for another section. 

✧ Select a section and click on Remove section to delete a section. 

✧ Under Execute, specify when the parallel line compensation is to be carried out and, if necessary, the IEP/
IE ratio in %. 

✧ Confirm your settings with OK.

Field Meaning

Name Name of the line section

Length Length of the line section in km/miles*

* Depends on the input format, the remaining variables are calculated.

Type Type of the line section. 
Available options are “Overhead Line“, “Three-core cable“ and 
“Single-core cable”.
This information is used to determine appropriate values for the 
zero capacity.

Central Phase The phase in the middle of the phase arrangement 

Resistance (R1)/resistance per unit 
length (R1')*

Ohmic equivalent resistance (absolute in Ω or relative in Ω/km)

Reactance (X1)/reactance per unit 
length (X1')*

Inductive resistance (absolute in Ω or relative in Ω/km)

Impedance (Z1)/impedance per unit 
length (Z1')*

Impedance (absolute in Ω or relative in Ω/km)

Line impedance angle The displacement of the line to the impedance phase.

Capacity (Cb)/capacity per unit length 
(Cb')*

Effective capacity
If this is not known then you can also enter unknown. An appro-
priate value will then be calculated automatically depending on the 
type of line.

RE/RL, XE/XL Earth impedance matching over the conditioning: RE=R1*(RE/RL)

kL Magnitude, kL Angle Earth impedance matching over: kL = ZE/Z1

Z0/Z1 Magnitude, Z0/Z1 Angle Earth impedance matching over: Z0/Z1

RM/RL, XM/XL Coupling factors for parallel line compensation

Earth Current from Network Node From the drop-down list, select the network node with the earth 
current of which the parallel line compensation is to be carried out.

Nominal Operating Current Enter the nominal operating current in this field.
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3.10.2 Selecting the frequency source
From the fault record data, SIGRA 4 calculates further values such as harmonics or vector values. The network 
frequency is included as parameter in these calculations. 
The source of the network frequency is selected via the Settings dialog. The settings made in this dialog apply 
to all fault records. 

The following can be selected as Source Of Frequency:

• the fault record with the frequency specification in the *.CFG file

• the frequency calculated from the signal data by SIGRA 4 

• the frequency defined by the user
If the automatic detection methods calculate the wrong frequency, it is possible to define this frequency.

✧ Select the menu item Options > Settings.
The Settings dialog is opened. 

sigra205a.tif

Fig. 3-17 SIGRA 4, defining the frequency source of the fault record.

✧ Select the Source of the frequency. If selecting the option Manually Specify Frequency, additionally 
enter the power frequency in Hz. You can choose between 50 Hz and 60 Hz or enter any system frequency 
(e.g. 49.95 Hz). 

After having closed the dialog with OK, all views are refreshed taking into account the selected frequency value. 

3.10.3 Selecting harmonics
In the Add harmonics dialog it is determined which harmonics are to be available in the assignment matrix for 
adding and for displaying in the Time signals view.

Proceed as follows to select the harmonics:

✧ Select the menu item Insert > Harmonics.
The Add harmonics dialog is opened. 

✧ Select one or several signal(s). 

✧ Select the desired harmonics.

✧ Close the dialog with OK. 
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3.10.4 Parameterizing transformer data
✧ Select the signal properties of the individual signals of the fault record using the Assign Signals dialog 

or by clicking the signal names in the legend or axis labeling of the diagram (see chapter 4.10).

DIGRA205.tif

Fig. 3-18 SIGRA 4, parameterizing the signal properties of the analog signals.

✧ Specify whether the measured values of the fault record are available as primary or secondary values in 
the Recorded in fault record as drop-down list.

✧ In the Recorded in Fault Record in field, specify whether the recorded measured values are available 
as instantaneous or r.m.s. values.

✧ Enter the nominal transformer values in the Primary and Secondary boxes.

✧ Confirm your settings with OK.

NOTE
Negative nominal transformer values cause an inversion of the signal!  
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4.1 Overview
SIGRA 4 offers a variety of convenient functions for the analysis of faults in your network by enabling the indi-
vidual configuration of signals in graphical displays or tables. 
As well as calculating measured values, SIGRA 4 can also be used for calculating further values, such as im-
pedances or outputs.

For their graphical representation, the fault record data are organized as follows:

• signals are assigned to diagrams

• diagrams are combined in views.

The assignment options depend on the type of variables represented (currents, voltages, impedances, etc.). 
Context-sensitive plausibility checks are run on parameter assignments.

4.1.1 Views
SIGRA 4 displays the signals of a fault record in the diagrams or tables of the following views:

• Time signals

• Vector diagrams

• Circle diagrams

• Harmonics

• Table

• Fault locator

You can define the main parameters of a view, such as labeling, colors or diagram heights, in the 
View Properties dialog box.

For further details on the structure and contents of these views, please refer to chapter 1.3 to chapter 1.7.

When you open a fault record under SIGRA 4 for the first time, the measured signals are shown as r.m.s. values 
in the Time Signals view. 
Each signal is assigned to a diagram. 

NOTE
You can display any number of diagrams in the different views.
The Table view does not contain any diagrams.
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4.1.2 Diagrams
The layout of a graphical view is basically defined by the arrangement of the diagrams and the signal assign-
ment to the diagrams.

The following SIGRA 4 functions support the display of diagrams:
 

• Inserting diagrams

• Copying diagrams (using drag-and-drop or the clipboard)

• Deleting diagrams

• Defining the diagram properties

• Changing the order of the diagrams (via drag-and-drop)

4.1.3 Signals
The term signals applies to all variables included in the fault record and calculated by SIGRA 4. 
Moreover, you can define mathematical functions for calculated signals.
These are divided into the following groups:

• Analog signals

• Binary signals

• Status signals (time markers of significant events)

• Components of analog signals (fundamental component, harmonics)

The signals of a fault record can be displayed in any number of diagrams of the graphical views and in the table 
view.

You can use the following SIGRA 4 functions to display these records according to your individual require-
ments:

• Assigning signals

• Copying signals (using drag-and-drop or the clipboard)

• Deleting signals

• Defining the signal properties

NOTE
Each diagram can be assigned any number of signals. 
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4.2 View properties
The View Properties dialog box contains the following tabs:

• Table Columns and

• Graphics.

Table columns tab

You can configure the table of a view in the Table Columns tab. In this table, you can read the values of as-
signed signals at the instants set by the cursors.

DIGRA206.tif

Fig. 4-1 SIGRA 4, defining the number and contents of the table columns of a view.

✧ Select the view whose table columns you want to configure from the View drop-down list;

✧ in the Fields not Displayed box, select all values you want to display (multiple-selection possible) and 
click the double arrow pointing to the right.

The values are entered in the Display these Fields in this Order box.

✧ If you want to change the order of the table columns, select a value in this box and click the Up or Down 
button;

✧ confirm your settings with OK;

✧ if you no longer want to show a value in the table, select this value in the Display these Fields in this 
Order box and click the double arrow pointing to the left.
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Graphics tab 

The Graphics tab lets you specify the design of the different views by defining the settings such as color, font, 
axis labeling, gridlines, etc. according to your individual requirements.

The setting of these parameters applies to all diagrams of a view.

✧ Open the View Properties dialog box by choosing Properties from the context menu
or by selecting View > Properties from the menu bar.

DIGRA020.tif

Fig. 4-2 SIGRA 4, defining the diagram display of a view.

✧ Choose the view of the parameters to be shown or edited from the drop-down list in the View box.

✧ In the Display section, activate the Auxiliary Gridlines function by clicking the corresponding check box.

✧ In the Min. Number per Axis box, enter an absolute value directly or increase/decrease the displayed 
value by clicking the up/down arrows. This defines the minimum number of gridlines required.
The number currently displayed depends on the section of view being displayed.

✧ From the Text type drop-down list in the Fonts section, select the text element (e.g. axis labeling) for 
which you want to specify the font.

✧ Click the Font button to a secondary dialog box where you can define the font, size and color.

✧ Click the Color button in the Diagram section to switch to the next dialog box, where you can select a 
color or define a new shade.

✧ Change the Diagram height (screen) of the diagram view using the drop-down list. The diagram height 
is resized by the selected percentage. 

NOTE
You can also set the resize factor for screen display using the toolbar (100%). 
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4.3 Inserting diagrams
To insert a diagram in a graphical view, choose one of the following options:

✧ Select Insert > Diagram from the menu bar.
The empty diagram is inserted at the end of the view;

or

✧ select a diagram and insert a new diagram by selecting Insert > Diagram from the menu bar or New from 
the context menu. The empty diagram is inserted above the selected diagram;

or

✧ paste a copied diagram from the clipboard by choosing Paste from the context menu or by selecting 
Edit > Paste from the menu bar (see chapter 4.4).
If a diagram is currently selected, the new diagram is placed above the selected one. If no diagram is 
selected, the new diagram is inserted at the end of the view;

or

✧ select a diagram in a view, keep the left mouse button pressed and drag and drop it to the target position 
in the same or another view;

or 

✧ select Edit > Assign Signals from the menu bar to open the Assign Signals matrix;

✧ click the header of a saved diagram or click a separating column and insert a new diagram by selecting 
New from the context menu.
The new diagram is inserted above the selected one and automatically assigned a default name. 

NOTE
A newly inserted diagram (without signal assignment) is initially "neutral". The diagram type (analog, binary, 
etc.) is defined only after the first signal has been assigned. If you insert a binary signal, a binary signal diagram 
is created, if the first signal is an analog signal, an analog signal diagram is created. 
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DIGRA024.tif

Fig. 4-3 SIGRA 4, inserting a diagram in the Time Signals view.
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4.4 Dragging and dropping / copying diagrams

Dragging and dropping a diagram

Diagrams can be dragged and dropped within a view. 

Proceed as follows:

✧ Select the diagram you want to drag and drop. 

✧ Keeping the right mouse button pressed, drag and drop the selected diagram via the drag-and-drop 
function to the target position.

Copying diagrams

You can reproduce diagrams using the Copy function. When copying, all parameters such as graphical layout 
and signal assignment are also copied.

Proceed as follows:

✧ Select the diagrams you want to copy in the corresponding view or in the Assign Signals dialog box.

✧ Select Copy from the context menu.

or

✧ Select Edit > Copy from the menu bar.

or 

✧ Click the button on the toolbar.

or

✧ Select the diagrams in the view that you want to copy.

✧ Keeping the left mouse button pressed, drag the selected diagram and drop it onto the target position 
(view, other application).

In Copy mode, the selected diagrams are placed on the clipboard and can then be pasted into a view at the 
selected point (see chapter 4.3).

Copy functions are basically possible between all views. For example, if you copy an analog signal diagram 
from the Time Signals view, you can paste it into a Vector Diagrams view or vice versa. 

NOTE
Diagrams copied to the clipboard can also be pasted into other applications, such as Word files. The copied 
diagrams is saved as a Windows metafile (*.wmf). 
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4.5 Deleting diagrams
If you want to delete diagrams from graphical views, proceed as follows:

✧ Select the diagrams you want to delete directly in the view or in the Assign Signals dialog box.

✧ Select Delete from the context menu.

or

✧ Select Edit > Delete from the menu bar.

or

✧ Click the button on the toolbar.

The selected diagrams are deleted from the view and from the Assign Signals matrix.
83SIPROTEC, SIGRA 4, Manual
E50417-H1176-C070-A6, Edition 02.2011

http://siemens-russia.com/


Views / Diagrams / Signals / Tables

4.6 Diagram properties

SIGRA_MANUAL_A6_EN.book  Page 84  Monday, February 21, 2011  8:08 AM
4.6 Diagram properties
The Diagram Properties dialog box lets you define the diagram layout with regard to name, labeling and scaling.

To open the Diagram Properties dialog box, proceed as follows:

✧ Select a diagram.

✧ Select Object Properties from the context menu.

or

✧ Select Edit > Object Properties from the menu bar.

DIGRA028.tif

Fig. 4-4 SIGRA 4, an example of editing the diagram properties.

The Diagram list box shows the names of all diagrams of the fault record. The name of the selected diagram 
is highlighted.

✧ You can change the diagram name in the Name box.

✧ Specify the height of the diagram in the Diagram height section by entering an absolute value in mm or 
increasing/decreasing the value by clicking the up/down arrows. The diagram height is only relevant when 
printing out the fault record. You can resize the diagram height of the on-screen display using the toolbar 
(100%).

✧ In the Display section, activate the various labeling options of the diagram by clicking the corresponding 
check box.
The functions that can be activated depend on the type of diagram selected.

Under Display, the following options can be activated: 

• Name
The text entered in the Name field is displayed. 

• Legend
The legend of the diagram is displayed. The legend is required to drag and drop signals between the 
diagrams via the drag-and-drop function.

• Label Signals
The signal labels are displayed.
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✧ Click the Scale button.

✧ Enter the start value and the end value for the X and Y-axes separately in the scale section.
The boxes available for the parameter settings depend on the type of diagram selected.
In the case of vector diagrams, enter the values for the left and right-hand diagrams of the view.
In the Circle Diagrams view, the representation is conformal. This may mean that the displayed area is 
larger than the value specified.

In the case of diagrams which display different signals, e.g. currents and voltages, all the corresponding 
scales are shown.

✧ To set the individual scales, select the corresponding value from the axis drop-down lists and parameterize 
the start and end values.

✧ You can switch to the parameter settings of another diagram by clicking another diagram name in the 
Diagram list box.

NOTE
If you want to change the properties of several diagrams simultaneously, you can select all these diagrams in 
the Diagram list box.
When using the multiple selection function, any properties which can be changed only in specific diagram 
types are grayed by SIGRA 4. 
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4.7 Assigning signals
To assign signals to the diagrams of the views, and the Table view, use the

• drag-and-drop function or the

• Assign Signals dialog box

Drag-and-drop

Proceed as follows:

✧ Select the signals in the legends or the axis labeling of a diagram (multiple-selection possible) and, 
keeping the left mouse button pressed, drag the signals to the target diagram of the same or another view, 
or to the Table view.

Assign Signals dialog box

The Assign Signals dialog box lets you individually assign the signals of a fault record to the diagrams of 
graphical views and the Table view.

This assignment is carried out in a table where

• each column corresponds to a diagram and

• each row corresponds to a signal.

The signals are grouped by

• analog signals

• binary signals

• status signals

• symmetrical components

• impedances

• powers

• fault locator

NOTE
The signal names of the variables calculated by SIGRA 4 are marked by an asterisk *. 
Signal names of supplementary fault records are extended by an index (see chapter 3.3). 
If signals have been assigned to more than one network node, the signal names are given the network node 
name as an extension (see chapter 3.10). 
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DIGRA025.tif

Fig. 4-5 SIGRA 4, assigning signals to the diagrams.

✧ Assign the signals to the diagrams by clicking the corresponding cell:
- empty cells are assigned,
- previous assignments are canceled;

or

✧ change the assignment via the context menu by choosing X (assigned) or _ (unassigned)

or

✧ type an X for assignment or delete the assignment by pressing the spacebar.

NOTE
If assignment is not possible, such as binary signal representation in a vector diagram, the mouse pointer 
changes and the corresponding box is grayed. 
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4.7.1 Opening the Object Properties dialog boxes
In the Assign Signals dialog box, you can open further dialog boxes to parameterize the following object prop-
erties:

• View properties

• Diagram properties

• Signal properties

Proceed as follows:

View properties

✧ Click the column header displaying the name of the view and open the View Properties dialog box by 
selecting Properties from the context menu.

Diagram properties

✧ Click the F button of a column (diagram) to open the Diagram Properties dialog box;

or

✧ click the column header (diagram) and open the Diagram Properties dialog box by selecting Properties 
from the context menu.

Signal properties

✧ Click the F button of a row (signal) to open the corresponding Signal Properties dialog box for:

• Analog signals or

• Binary signals or

• Status signals

or

✧ Click the name of a signal and open the Signal Properties dialog box by selecting Properties from the 
context menu.

or

✧ Click the symbol of a signal, e.g. the line symbol and open the Signal Properties dialog box by selecting 
Properties from the context menu.
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4.7.2 Hide / Show areas
For a better overview, it may be necessary to temporarily hide or show some parts of the assignment matrix 
(columns / rows) in the display.

The following areas can be minimized /maximized:

• Views

• Diagrams

• Signal groups (analog, binary, impedances, etc.)

• Signals column

• Name column (signal)

• Line column (signal)

To find out if an area of the table can be hidden/shown, place the mouse pointer above the relevant area (col-
umn/row header) and a tooltip appears with the required information.

✧ Double-click the header of a column (e.g. diagram).
The column is minimized/maximized.

✧ Double-click a signal group (e.g. analog).
The group is minimized/maximized.

✧ Double-click the Line column (signals).
The graphical display of the signals is minimized / maximized.

 

DIGRA023.tif

Fig. 4-6 SIGRA 4, changing the display of the Assign Signals dialog box.
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4.8 Copying signals
You can use the Copy function to reproduce signals. When copying, all parameters, such as colors and line 
styles, are also copied.

Analog signals

Proceed as follows:

✧ Select the signals you want to copy in the legend or axis labeling of a diagram or in the table row of the 
Table view. 

To display the legend, activate the Legend option in the Diagram Properties dialog, see paragraph 4.6.

✧ Keeping the left mouse button pressed, drag the signal and drop it onto the target position (diagram, 
view). 

or

✧ Select Copy from the context menu.

or

✧ Select Edit > Copy from the menu bar.

or

✧ Click the button on the toolbar.

All selected signals are saved to the clipboard from where they can be pasted into the diagrams of individual 
views.

✧ Select the diagrams in which you want to insert the signals;

✧ paste the copied signals from the clipboard by selecting Paste from the context menu, selecting 
Edit > Paste from the menu bar or by clicking the button on the toolbar. 

Binary signals

To copy binary signals, proceed as follows:

✧ Select the labeling of the binary signals in the diagram and copy it using the drag-and-drop function, 
by selecting Copy from the context menu, via the menu commands Edit > Copy or by clicking the Copy 
button on the toolbar.

In Copy mode, the binary signals are placed on the clipboard from where they can be pasted into other binary 
signal diagrams.

NOTE
During the Paste operation, SIGRA 4 checks the plausibility of the selection. 
For example, if you choose a status diagram as the target for a binary signal, the Paste function is disabled. 
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Status signals

To copy status signals, proceed as follows:

✧ Select the status signals in the status diagram and copy it using the drag-and-drop function, by 
selecting Copy from the context menu, via the menu commands Edit > Copy in the menu bar or by 
clicking the Copy button on the toolbar.

In Copy mode, the status signals are placed on the clipboard from where they can be pasted into other status 
signal diagrams.
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4.9 Deleting signals

Analog signals

If you want to delete analog signals from the views, proceed as follows:

✧ Select the signals you want to delete in the legend or axis labeling of a diagram or in the table row of 
the Table view.

✧ Select Delete from the context menu.

or

✧ Select Edit > Delete from the menu bar.

or

✧ Click the button on the toolbar.

The selected signals are deleted from the diagram.

Binary signals

To delete binary signals, proceed as follows:

✧ Select the labeling of the binary signals in the diagram and choose Delete from the context menu or 
select Edit > Delete from the menu bar or click the button on the toolbar.

Status signals

To delete status signals, proceed as follows:

✧ Select the status signals in the status diagram and delete them by choosing Delete from the context 
menu or by selecting Edit > Delete from the menu bar or by clicking the button on the toolbar.

The status signal is deleted from the display.

NOTE
These signals remain in the SIGRA 4 data management, so that they can be reinserted in the diagrams of the 
graphical displays or the Table view at any time via the Assign Signals dialog. 

NOTE
If you delete a user-defined status signal from its last display, it is also deleted from the SIGRA 4 data manage-
ment. 
The status signal which marks the trigger instant for fault record recording can only be deleted from the display. 
However, it is still in the Assign Signals matrix. 
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4.10 Signal properties
In the Signal Properties dialog box; you can define the layout properties of a signal; such as color, line style or 
marker.

The signal properties are defined separately for:

• Analog signals

• Binary signals

• Status signals

4.10.1 Analog signals
To open the Signal Properties dialog box for analog signals, proceed as follows:

✧ Select a signal in the legend or the axis labeling of the diagram and select the signal properties via 
Object Properties in the context menu or via Edit > Object Properties in the menu bar.

or

✧ Click the F box in front of the signal names in the Assign Signals matrix.

or

✧ Mark the Signal name or Signal Line column in the Assign Signals matrix and open the signal 
properties by selecting Properties from the context menu.

or

✧ Select the signal names in the Table view.

DIGRA041a.tif

Fig. 4-7 SIGRA 4, defining the display format of an analog signal. 
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The Signal list box shows the names of all signals available. The name of the selected signal is highlighted.

The Name text box shows the name of the signal selected. This name cannot be changed.

✧ Select the Line style from the drop-down list where the different types of line display such as line, dots or 
dot-and-dash are listed;

✧ use the Line weight box to enter the line weight of the signal directly as an absolute number of pixels or 
by increasing/decreasing the value by clicking the up/down arrows;

✧ use the Marker type box to specify if you want the sampling instant of a signal to be marked by graphical 
symbols;

✧ click the Color button to switch to a secondary dialog box, where you can select a color or define a new 
shade;

✧ check your settings in the Preview section;

✧ confirm with OK.

By clicking another signal name in the Signal list box can switch to the parameterization for this signal. 

Transformer data

As well as defining the parameter settings of the graphical representation, this dialog also lets you define the 
transformer data of the signal. You need this information for the analysis of fault records which do not contain 
this information, such as fault records which were not recorded by DIGSI 4 (see chapter 3.10).

✧ Specify whether the measured values of the fault record are available as primary or secondary values in 
the Recorded in Fault Record in drop-down list.

✧ In the Recorded as field, specify whether the recorded measured values are available as instantaneous 
or r.m.s. values.

✧ Enter the Nominal Transformer values in the Primary and Secondary boxes.

✧ Confirm with OK.

NOTE
If you want to change the properties of several signals simultaneously, you can select all these signals in the 
Signal box. 
When using the multiple selection function, any properties which can be changed only for specific signals are 
grayed by SIGRA 4. 
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4.10.2 Binary signals
To open the Signal Properties dialog box for binary signals, proceed as follows:

✧ Select a signal in the diagram labeling and open the Signal Properties dialog box by choosing 
Object Properties in the context menu or by selecting Edit > Object Properties from the menu bar.

or

✧ Select the Signal name or Signal Line column in the Assign Signals matrix and open the signal 
properties by selecting Properties from the context menu.

DIGRA041b.tif

Fig. 4-8 SIGRA, defining the display format of an binary signal. 

The Signal list box shows the names of all signals available. The name of the selected signal is highlighted.

The Name text box shows the name of the signal selected. This name cannot be changed.

✧ Click the Color button to switch to a secondary dialog box, where you can select a color or define a new 
shade.

✧ Check your settings in the Preview section.

✧ Confirm with OK.

By clicking another signal name in the Signal list box can switch to the parameterization for this signal.

NOTE
If you want to change the properties of several signals simultaneously, you can select all these signals in the 
Signal box. 
When using the multiple selection function, any properties which can be changed only for specific signals are 
grayed by SIGRA 4. 
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4.10.3 Status signals
Status signals are used for the time marking of events.

To open the Signal Properties dialog box for status signals, proceed as follows:

✧ Select a signal in the status diagram and open the Signal Properties dialog box by choosing Object 
Properties from the context menu or by selecting Edit > Object Properties from the menu bar,

or

✧ select the Signal name or Signal Line column in the Assign Signals matrix and open the signal 
properties by selecting Properties from the context menu.

DIGRA041c.tif

Fig. 4-9 SIGRA, defining the display format of a status signal.

The Signal list box shows the names of all signals available. The name of the selected signal is highlighted.

The Name text box shows the name of the signal selected. The names of user-defined status signals can be 
changed.

✧ Select the Line style from the drop-down list where the different types of line display such as line, dots or 
dot-and-dash are listed.

✧ Use the Line weight box to enter the line weight of the signal directly as an absolute number of pixels or 
by increasing/decreasing the value by clicking the up/down arrows.

✧ Use the Marker type drop-down list to specify the marker symbol to be used for displaying the status 
signal in the status diagram.

✧ Click the Color button to switch to a secondary dialog box, where you can select a color or define a new 
shade.

✧ Check your settings in the Preview section.

✧ Confirm with OK.
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NOTE
If you want to change the properties of several signals simultaneously, you can select all these signals in the 
Signal box. 
When using the multiple selection function, any properties which can be changed only for specific signals are 
grayed by SIGRA 4. 
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4.11 Generating calculated signals
With SIGRA 4, you can define mathematical functions. These functions are used to generate calculated sig-
nals. The basic arithmetic operations +, -, *, and / are available as mathematical operators. 
As output signals for the calculation you can use the measuring signals as well as the signals calculated by 
SIGRA 4.

The calculated signals are identified with * in the signal matrix. There, the signals can be assigned to the dia-
grams. 

Generating a calculated signal

How to generate a calculated signal:

✧ Open a fault record. 

✧ Select the menu item Add > Calculated signal.
The Add calculated signal window opens. 

SIGRA220.tif

Fig. 4-10 SIGRA, defining the mathematical function and name of a calculated signal.

The following is a description of how to generate a sum signal from 2 currents. Other signals can be generated 
analogously with the help of mathematical functions. 

✧ Enter the designation Sum IL1, IL2 for the calculated signal in the Name field. 

✧ In the Select signals field, double-click the signal IL1. 

✧ Click on the operation +. 

✧ In the Select signals field, double-click the signal IL2. 
The mathematical function IL1+IL2 is displayed in the Calculation field. 

✧ Close the dialog Add calculated signal with OK. 
The calculated signal is saved.

✧ Select Edit > Assign Signals. 
The Assign Signals window is opened. 
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SIGRA221.tif

Fig. 4-11 SIGRA, assigning the calculated signal to a diagram.

The new signal is listed and identified with its name and an *. It can now also be assigned. 

NOTE
The mathematical functions for the calculated signals are saved in the *.DG4 file of the respective fault record 
and are therefore only available for this fault record. 
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4.12 Configuring tables
You can set up the layout of the tables displayed in the views of the fault record in a dialog. The settings can 
be changed again at any time.

Table view

To configure the Table view, proceed as follows:

✧ Open the Assign Signals dialog box (see chapter 4.7).

✧ Select all the Signals whose values you want to display (table rows).

✧ Confirm with OK.

✧ Open the View Properties dialog box (see chapter 4.2).

✧ Select all the values you want to display, such as real part, imaginary part and phase position of the 
fundamental. This selection produces the table columns.

✧ Confirm with OK.

Table of the graphical views

The table rows of the table in the graphical views are assigned to cursors. To measure a fault record in the 
Time Signals, Vector Diagrams or Circle Diagrams views, you work with both cursor 1 and cursor 2, while in 
the Harmonics view you only work with cursor 1.

To configure the table columns, proceed as follows:

✧ Open the View Properties dialog box (see chapter 4.2).

✧ Select all the values you want to display, such as r.m.s. value, instantaneous value, balanced component, 
extreme value.

✧ Confirm with OK.
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4.13 User profiles 
In SIGRA 4, you can define user profiles to simplify the analysis of fault records.

Design the layout of a fault record in the various diagram views according to your requirements and save your 
settings in the User Profile dialog under a name of your choice.

All specified parameters, such as signal assignment to the individual diagrams, types of color, labeling, line 
styles, etc. are then permanently available under this name and can be assigned to the individual fault 
records.

You can use this method to temporarily assign a special layout to a fault record for printing on a monochrome 
printer which differs from the one used for the fault record analysis on the screen.

Depending on the devices used, the types and volume of the measured values and binary signals shown in the 
fault record may differ.
The signal display in the fault record can be matched accordingly.

For this reason it is advisable to define a suitable user profile for each device type and allocate it to the fault 
record of this device. When loading a fault record from the corresponding device, the parameter settings of this 
user profile are used automatically for display.

Scaling in groups

When you open a fault log or activate either a predefined user profile or a user profile you have configured your-
self, all of the signals that belong to a scaling group are displayed using the same scale on the Y axis.

The minimum range for the display is calculated in such a way that it is not purely dependent on the maximum 
values of the signals contained. The minimum range is set to min. 5% of the nominal value of the signals.
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4.13.1 Defining and saving a user profile 
To define a user profile, proceed as follows:

✧ Design the layout your fault record (views, diagrams) with regard to signal assignment, color, lines and 
text fonts, table configuration, etc. according to your requirements.

✧ Select the User Profile dialog box via the Options > User Profile menu command or the button on the 
toolbar.

DIGRA050.tif

Fig. 4-12 SIGRA, defining a user profile. 

✧ Click the Add button, enter the name of the new user profile in the secondary dialog box and confirm with 
OK.

✧ Enter a short description of the fault record layout in the Comment text box of the User Profile dialog box.

✧ Confirm with OK.

NOTE
User profiles are saved in the SIGRA4.upf file. 
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4.13.2 Allocating a user profile
If you wish to use a previously defined user profile for the analysis of a fault record, proceed as follows:

✧ Select a user profile, such as One Signal per Diagram, from the drop-down list on the View toolbar.

The variables of your fault record are calculated according to the user profile definition and displayed in the 
various views.

4.13.3 Deleting a user profile
To delete a SIGRA 4 user profile, proceed as follows:

✧ Select the User Profile dialog box via the Options > User Profile menu command or the button on the 
View toolbar.

✧ Select the user profile you want from the drop-down list in the User Profile box.

✧ Click the Delete button.

✧ Confirm with OK.
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4.13.4 Automatically apply user profile
If you want to apply the same user profile to fault records of one device type, assign this profile to the respective 
device type. When loading one of these fault records, SIGRA 4 then automatically applies the corresponding 
definition.

Proceed as follows:

✧ Select the User Profile dialog box via the Options > User Profile menu command or the button on the 
toolbar;

✧ select a user profile from the drop-down list in the User Profile box;

✧ click the Automatically Apply button;

DIGRA202c.tif

Fig. 4-13 SIGRA 4, an example of defining the application of a user profile.

✧ in the Automatically Apply User Profile When Loading... section, select a device type from the Defined 
Device Types box and click the double arrow pointing to the right.

The device type is now moved to the right box ...Fault records with the Following Device Types thus assign-
ing it to the selected user profile.

This list shows all the device types assigned to the selected user profile.

You can undo your selection by clicking double arrow pointing to the left (<<).

✧ Confirm with OK;

or

✧ click the Apply button, if you want to assign further user profiles and devices.
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Inserting a device type

If you are analyzing the fault record of a device type which is not contained in the Defined Device Types list, 
supplement the list as follows:

✧ Select the User Profile dialog box via the Options > User Profile menu command or the button on the 
toolbar;

✧ click the Automatically Apply button;

✧ click the New Type and open a secondary dialog box;

✧ in this dialog box, you can type the name under which you want to save the device type in the user profile 
management.

You can also combine several device types to groups and save their names by adding an asterisk), e.g. 7SA*. 
The assigned user profile is then applied to all devices whose names start with 7SA.

To delete device types, proceed as follows:

✧ Select the User Profile dialog box via the Options > User Profile menu command or the button on the 
toolbar;

✧ click the Automatically Apply button;

✧ select the types you want to delete in the Defined Device Types box (multiple-selection possible);

✧ click the Delete button;

✧ confirm with OK.

NOTE
The device name is part of a fault record in COMTRADE format. 
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4.14 The fault locator
Measurement of the distance to a fault in the event of a short circuit is a valuable addition to the functionality 
of the protection device. The line availability for network power transmission can be increased by faster location 
of the fault location and thus more rapid fault clearing.

4.14.1 Functional description

General

The fault locator is an independent and autonomous function, which allows the precise location of faults even 
on mixed line sections by using the line data entered. For double ended lines SIGRA also allows bidirectional 
fault location (optional), which enables significantly improved fault location, especially for lines with feed from 
both ends, faults involving earth, or faults with high resistance.

Unidirectional fault location takes place in any case. If data for the remote end of the line are also available then 
three fault locations are located in total:

✧ One calculated by means of bidirectional fault location

✧ Two calculated by means of unidirectional fault location (one from each end)

Using the accuracies determined it is easy to determine the most probable location of the fault. Usually the fault 
location calculated by bidirectional fault location is the most accurate, although for high current faults in the 
close vicinity of one end of the line the unidirectional fault location may be more reliable.

The object being protected may be an inhomogeneous line. The line may also be split into several sections for 
the calculation, for example, a short cable followed by an overhead line. For such configurations the line sec-
tions can be parameterized individually.

The system converts measurement errors, line symmetry and geometry based on the known voltage profile on 
the line into a difference in distance to decide whether to carry our bidirectional fault location. If this difference 
in distance is too great, in relation to the line section in question, then the result of the bidirectional fault location 
is rejected and the distance is only displayed as that calculated using unidirectional fault location. The calcu-
lated accuracy is reported on a scale from 0 to 10 with increasing accuracy.

Double faults with different base points, source-side faults and faults which are not on the line between the two 
measuring points are only calculated and displayed using unidirectional fault location.

Fault location using the unidirectional fault locator

The principle behind the method used for locating the fault is very much based on the method used by distance 
protection. The impedance is also used here.

First of all the fault record is broken down into its various parts by step analysis (for example, pre-fault, fault, 
disconnection).

The impedance is then calculated for the various states. This also takes the various line sections into account.
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Bidirectional fault location

Bidirectional fault location also takes the line capacity and resistance into account. A great advantage of bidi-
rectional fault location is that the claculation does not need earth impedance, which is often not known in ade-
quate detail.

The bidirectional method of fault location assumes that, for an unbranched line with known current and known 
voltage and the feeders, the voltage at each point, x, can be calculated. This applies to both ends of the line. 
Since the voltage must be equal whichever end of the line it is calculated from, the error has to be at the point 
where the voltage curves cross. The voltage curves are calculated according to the telegraph equation using 
currents and voltages measured locally, and the impedance per unit length of the line. Figure 5-12 shows a 
simplified representation of this, assuming linear voltage characteristics.

Fig. 4-14 The voltage characteristics on a faulty line (simplified). 

The bidirectional method of fault location used here has the following advantages in comparison to unidirec-
tional fault location:

• Accurate fault location is also possible when there is power flow, on doubly fed lines and if there is a high 
fault resistance;

• inaccurate setting of the earth impedance does not affect the accuracy of the fault location;

• the accuracy can be improved by taking the line asymmetry into account (by selection of the central 
phase);

• it is not necessary to locate the fault loop, which is often difficult.

Fault location results

The results of the fault location display the:

• Short-circuit loop, from which the fault reactance is measured

• The fault location in miles

• The resistance R of the fault loop in Ω primary

• The distance d of the fault proportional to the reactance in kilometers or miles of line, converted on the 
basis of the parameterized reactance per unit length of the line

• The distance d of the fault in % of line length, calculated on the basis of the parameterized reactance per 
unit length of the line and the parameterized line length

All of the results obtained are displayed: if only one fault record is available only the data for a unidirectional 
fault location, if two fault records are available bidirectional fault location is displayed.
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Line sections

The line data can be entered in the network configuration. A line may consist of several line sections, for ex-
ample an overhead line that leads on to a cable.

For each line section you can enter the type. This setting affects the measurement process, since a cable has 
other physical characteristics than an overhead line.

To simplify data entry, it is possible to enter the line data in a variety of formats. For instance, the line impedance 
can be entered as the total impedance or as the relative impedance (Ω per km or mile).

There are also other tools to assist with data entry. For example, if the line capacity is not known, then a default 
value determined using a physical model can be used.

DSGRA207.tif

Fig. 4-15 SIGRA 4, making the fault locator settings. 

For information on the parameterization of a line, please refer to paragraph 3.10.1. 

You can select when the parallel line compensation is to be carried out and the IEP/IE ratio in %, if necessary. 
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Line symmetry (only for bidirectional fault location)

To achieve greater accuracy for bidirectional fault location, the line asymmetry can be taken into account. The 
line asymmetry is estimated on the basis of the layout of the conductors.
The central phase needs to be configured. If you do not want an estimation of the line asymmetry to be carried 
out then it can be deactivated. Lines are assumed to have a high degree of symmetry around the central phase, 
in particular the single-plane layout. 

Figure 4-16 shows 2 mast systems with different phase arrangements. The phases are indicated by the + signs. 
In both arrangements, L2 is the central phase.

The central phase is parameterized in the Network Configuration dialog, Fault Locator tab. 

Twisted lines can be simulated by entering several line sections with different central phases.

Fig. 4-16 Different options for a single-plane arrangement with a central phase. 

L1 L2 L3

L1

L2

L3
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4.14.2 Using the fault locator
In order to carry out a fault location, proceed as follows:

✧ Load a fault record;

✧ import a second fault record (for example by drag-and-drop);

✧ select the Fault Locator tab via the Options > Network Configuration menu command (see Figure 5-13);

✧ enter the parameters for the line sections;

✧ now select the menu item View > Fault Locator to start calculation of the fault location. 

✧ If the calculation is carried out correctly save the network configuration for future use. The next time a fault 
record is received from the same devices the right configuration can then be selected automatically.

NOTE
The fault records are synchronized automatically. 

NOTE
If the earth current of the parallel line is available, this can be taken into account for the unidirectional fault lo-
cator, see paragraph 3.10.1. The bidirectional fault locator is not affected by that. 
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5.1 Device fault records
The devices of the SIPROTEC series continuously record measured values and binary signals. These are 
saved in case of events, such as when a fault occurs or after an operator action, which can be parameterized 
for specific devices.

These data are read out via the parameterization software DIGSI 4 or a higher DIGSI version and saved as 
fault record in COMTRADE format. 

On the basis of these data, SIGRA 4 calculates additional variables, such as impedances, and makes these 
variables and the measured values available for the graphical fault record analysis.

These procedures are based on conventions observed with all devices of the SIPROTEC product family.

SIGRA 4 has been designed as a device-independent analysis program, which can interpret any fault records 
available in a COMTRADE format. For this reason, it may become necessary to adapt the sequence of the val-
ues supplied, their physical meanings or the calculation parameters to the SIGRA 4 reference arrow system 
(see chapter 5.3).
These adjustments can be made in the Network Configuration and Signal Properties - Analog Signals di-
alogs.
For further details, please refer to chapter 3.10 and chapter 4.10.

The following chapters describe the handling of the measured variables and the reference arrow definition 
in three-phase systems.
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5.2 Principles for the calculation of process variables
Calculations performed by SIGRA 4 always refer to primary values.

SIPROTEC devices

The transformation of the measured variables to the primary system is based on the following relations:

The nominal values of the transformers are entered in the COMTRADE file of the fault record by DIGSI 4 or a 
higher DIGSI version and can thus be evaluated by SIGRA 4. 

These settings can be checked and changed, if necessary, in the Signal Properties dialog, Analog Signals 
tab (see chapter 4.10).

Non-company devices

If you wish to analyze fault records from non-company devices which record the secondary values of the mea-
sured variables, you need to use the nominal transformer variables to ensure correct transformation of these 
values to the primary system. These parameter settings are specified in the Signal Properties - Analog Sig-
nals dialog (see chapter 4.10).

The display of the calculated values in the secondary system is always based on the ratio of the main current 
or main voltage transformers.

Measuring window

If calculated variables are created via a measuring window, the window is always located to the left of the ref-
erence instant, e.g. the cursor position. The length of the measuring window corresponds to one period of 
the nominal frequency TN, e.g. 20 ms at 50 Hz. SIGRA 4.3 includes an algorithm that determines the actual 
network frequency on the basis of the pre-fault condition. This frequency is shown in the status bar and is used 
as the basis for the calculations.

Vp = Vs × VNp / VNs

Ip = Is × INp / INs

VNp: primary nominal transformer voltage

VNs: secondary nominal transformer voltage

INp: primary nominal transformer current

INs: secondary nominal transformer current

NOTE
Negative nominal values result in a 180o rotation of the measured signal. You can use these values to es-
tablish compatibility when defining the SIGRA 4 reference arrow system. 
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Frequency measurement

Frequency measurement determines the network frequency on the basis of the pre-fault state:

• determination using IL1, IL2 and IL3 or VL1E, VL2E and VL3E by forming the positive sequence space 
vector,

• assessment of the pre-fault state,

• the frequency is determined using the length of the pre-fault state and the angle of the positive sequence 
space vector during this period,

• the criteria for a valid value are: I1 > 5% Inom, f > 5% fnom,
Tpre > 1/fnom or at least 20 sampling points, or V1 > 5% Vnom, f > 5% fnom, Tpre > 1/fnom or at least 
20 sampling points.

If a frequency can be determined then it is taken as the nominal frequency for the fault record and is displayed 
in the status bar, and is also taken as the default value for all subsequent calculations.

If no valid frequency can be determined then frequency analysis is not carried out and the value given in the 
COMTRADE file is used instead.

Additionally, frequency analysis is carried out for each network node in order to reveal the frequency curve of 
the signals and to provide this as a signal which can optionally be inserted into a diagram.

The analysis is also done using the space vector analysis, preferably with the voltages, but if these are not 
available then with the currents. As the measuring window for the frequency analysis the usual backward look-
ing window with a length of 1/Fnom is chosen.

NOTE
The calculated values are valid only if there is no status change, (such as fault occurrence or disconnec-
tion), within the measuring window. 

NOTE
All variables calculated by SIGRA 4 are identified by an asterisk. 

NOTE
The variables calculated by SIGRA 4 cannot always be used to draw conclusions on the reaction of the protec-
tion device used to acquire the fault record data.
The algorithms on which the protection devices base their internal calculations may deviate from standard 
SIGRA 4 conventions. Deviations may occur, particularly in the case of variables which are not perfectly sinu-
soidal.  

The calculated values are valid only if there is no status change, (such as fault occurrence or disconnec-
tion), within the measuring window.  
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5.3 Reference arrow definition
The calculations performed by SIGRA 4 are based on the following reference arrow definition:

Fig. 5-1 The reference arrow definition used by SIGRA 4 for calculations. 

5.4 Variables in the three-phase system
SIGRA 4 supplements the measured variables of the fault record by calculated variables, using the nodal or 
Kirchhoff equations in the three-phase system.

Calculation is based on the following relations and their conversion (for further details, see chapter 5.3 Refer-
ence arrow definition):

L1

L2

L3

N

E

IY

IL1P

IL2P

IL2P

IL1

IL2

IL3

VL3 VL2 VL1

VL23

VL12 VL31

IE = -3 I0

IEP = -3 I0P

VL12 = VL1 − VL2

VL23 = VL2 − VL3

VL31 = VL3 − VL1

VL12 + VL23 + VL31 = 0

Ven = 3V0 = VL1 + VL2 + VL3

IE = −(IL1 + IL2 + IL3)
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5.5 Symmetrical components
SIGRA 4 calculates the symmetrical components of the voltage and current system using the three-phase op-
erator a = e j2/3π according to the following equations: 

The complex conductor variables are r.m.s. values of the fundamental component (nominal frequency TN).

The measuring window is situated on the left of the reference point, e.g. the cursor position, and its length 
corresponds to one period of the nominal frequency TN.

5.6 R.M.S. values
The calculation of r.m.s. values is based on the following definition of r.m.s. values:

The measuring window is situated on the left of the reference point tc, e.g. the cursor position, and its length 
corresponds to one period of the nominal frequency TN.

5.7 Harmonics
Harmonics are calculated by means of a full-cycle DFT (Discrete Fourier Transformation) and are always 
r.m.s. values.

The measuring window is situated on the left of the reference point, e.g. the cursor position, and its length 
corresponds to one period of the nominal frequency TN.

5.8  Vectors
The absolute value of complex vectors are r.m.s. values of the fundamental component 
(nominal frequency TN), i.e. harmonics are filtered out.

The measuring window is situated on the left of the reference point, e.g. the cursor position, and its length 
corresponds to one period of the nominal frequency TN.

With currents and voltages, the vector angle always refers to a standard vector ej2πfNt rotating at nominal fre-
quency.

V1 = 1/3 ( VL1 + a VL2 + a2 VL3 )

V2 = 1/3 ( VL1 + a2 VL2 + a VL3 )

V0 = 1/3 ( VL1 + VL2 + VL3 )

I1 = 1/3 ( IL1 + a IL2 + a2 IL3 )

I2 = 1/3 ( IL1 + a2 IL2 + a IL3 )

I0 = 1/3 ( IL1 + IL2 + IL3 )
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5.9 Positive-sequence impedances
The positive-sequence impedances are calculated using the complex vectors of the voltages and currents of 
the three-phase system.
This is effected by considering the zero-sequence coupling and, if necessary, the inductive coupling to a parallel 
line.

SIGRA 4 calculates the positive-sequence impedances for all of the three 

• Conductor-to-earth loops (L1E, L2E, L3E) and

• conductor-to-conductor loops (L12, L23, L31).

For example, SIGRA 4 calculates the positive-sequence impedances using the results of the following equa-
tions:

Conductor-to-conductor loop L12:

Conductor-to-earth loop L1E without parallel line compensation:

Conductor-to-earth loop L1E with parallel line compensation:

VL12 = IL1 R1(L12) + jIL1X1(L12) −

IL2 R1(L12) − jIL2X1(L12)

VL1E = IL1    R1(L12) + jIL1   X1(L12) −

IE kr R1(L12) − jIE kx X1(L12)

VL1E = IL1         R1(L12) + jIL1         X1(L12) −

IE   kr    R1(L12) − jIE   kx    X1(L12) −

IEP kMr R1(L12) − jIEP kMx X1(L12)
117SIPROTEC, SIGRA 4, Manual
E50417-H1176-C070-A6, Edition 02.2011

http://siemens-russia.com/


Calculations / Definitions

5.10 Three-phase outputs

SIGRA_MANUAL_A6_EN.book  Page 118  Monday, February 21, 2011  8:08 AM
The following equation applies:

Z1 = R1 + jX1     =     ZL = RL + jXL

5.10 Three-phase outputs
SIGRA 4 calculates the following Three-phase outputs:

kr = RE / RL = (R0 / R1 −1) / 3

kx = XE / XL = (X0 / X1 −1) / 3

kMr = RM / RL = R0M / R1 / 3

kMx = XM / XL = X0M / X1 / 3

NOTE
With fault records of the SIPROTEC devices, the factors for earth impedance matching RE / RL und XE / XL 
as well as the factors for parallel line compensation are transferred by DIGSI 4 or a higher DIGSI version to 
SIGRA 4 together with the measured values. 

For fault records from other devices, you can parameterize these factors in the Network Configuration dialog 
(see chapter 3.10.1). It also lets you define if and under what conditions parallel line compensation is carried 
out. 

S = VL1 × IL1* + VL2 × IL2* + VL3 × IL3*

P = Re (S)

Q = Im (S)
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5.11 Formulas
The following list shows the meanings and a brief description of the formula symbols used.

R0M Mutual zero-sequence resistance (coupling resistance)

X0M Mutual zero-sequence reactance (coupling reactance)

R0 Zero-sequence resistance of the protected object (e.g. a line)

X0 Zero-sequence reactance of the protected object (e.g. a line)

kr = RE / RL = (R0 / R1 −1) / 3 Earth impedance matching, resistance ratio

kx = XE / XL = (X0 / X1 −1) / 3 Earth impedance matching, reactance ratio

kMr = RM /RL = R0M / R1 / 3 Coupling impedance matching, resistance ratio

kMx = XM / XL = X0M / X1 / 3 Coupling impedance matching, reactance ratio 

R1 Positive-sequence resistance of the protected object (e.g. a line)

X1 Positive-sequence reactance of the protected object (e.g. a line)

Z1 Positive-sequence impedance of the protected object (e.g. a line)

V1 Positive-sequence voltage

V2 Negative-sequence voltage

V0 Zero-sequence voltage

I1 Positive-sequence current

I2 Negative-sequence current

I0 Zero-sequence current

IL1 Conductor current, phase L1

IL2 Conductor current, phase L2

IL3 Conductor current, phase L3

IE Earth current

VL1 Voltage conductor L1 - earth

VL2 Voltage conductor L2 - earth

VL3 Voltage conductor L3 - earth

Ven Displacement voltage

VL12 Voltage conductor L1 - conductor L2
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VL23 Voltage conductor L2 - conductor L3

VL31 Voltage conductor L3 - conductor L1

S Apparent power

P Active power

Q Reactive power
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Literature

/1/ SICAM PAS, Overview
E50417-X8976-C431

/2/ SICAM PQS, Overview
E50417-X8976-C464

/3/ SICAM PAS/PQS, Configuration and Operation
E50417-P8976-C433

/4/ SICAM Valpro, Measured/Metered Value Processing Utility
E50417-H8976-C479

/5/ SICAM PQS, Fault Locator
E50417-H8976-C421

/6/ SICAM PQ Analyzer
E50417-H8976-C397

/7/ SICAM PQ Analyzer, Incident Explorer
E50417-H8976-C465

/8/ SIPROTEC DIGSI 4, Start UP
E50417-G1176-C152

/9/ SIPROTEC System Description, Manual
E50417-H1176-C151

/10/ Ethernet & IEC 61850, Start UP
E50417-F1176-C324

/11/ Ethernet & IEC 61850, Conzepts, Implementation, Commissioning
E50417-F1176-C361

These Documents can be ordered by your Siemens Partner. 
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Binary signals 90, 92, 95
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Office applications 66
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Sampling instants 51
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Session memory 14
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Analog signals 93
Binary signals 95
Status signals 96
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Assign 86
Assign Signals 14
Binary ~ 90, 92
calculate 98
Copy ~ 90
Names 55
Properties 15, 51, 93
Status 15, 18, 53, 54, 91, 92

SIPROTEC 67, 112
Status bar 13
Status signals 15, 18, 91, 92, 96

Delete ~ 54
Insert ~ 53

Synchronize 56
System overview 11

T
Tabelle 100
Table 13, 18, 20, 21, 24, 47, 49, 54, 78
Three-phase outputs 118
Time signals 17
Toolbar 29
Tooltip 18, 20, 22, 24
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U
User profile 46
User profiles 14

Assign ~ 104
Define ~ 102
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V
Vector Diagram 19
Vector Diagrams 85
View 46, 76

Circle Diagrams 21, 50
Display 32
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Table 25
Time signals 17
Vector Diagram 19
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View properties 78, 88

W
Word 66
www.siemens.com/power-academy-td 3

Z
Zoom

Activate ~ 36
Axis scale 36
Match ~ 39
Optimize ~ 38
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